XML Schema Browser - careCreditRequest Version 450

Schema Documentation of
careCreditRequest V450

proposed standard of Sumex1

The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.

Copyright (©) by Sumex1, 06.05.2019 - all rights reserved


Revision history of the documentation

Documentation of the proposed careCreditRequest450 standard

Copyright (©) by Sumex1, 06.05.2019
All rights reserved

Revision history of the documentation

The following reversed chronological list shows the revision history of this documentation.

The revision history defines the time evolution of the documentation in the sense of a more precise phrasing and/or added parts.
However, the underlying careCreditRequest_450.xsd schema is not changed due to such an entry.
  • Initial documentation of the careCreditResponse_450.xsd schema


Preface

Preface

Audience of this documentation
The target audience of this documentation are primarily software developers of the Swiss healthcare sector.
An understanding of Swiss healthcare concepts (e.g. Tiers garant vs. Tiers payant and the like) as well as at least a basic knowledge about XSD schemas is presumed to be known.
How to use this documentation
There are two different views of this documentation.
  • the Hierarchical list view starts from the topmost object. By selecting a shown element one can explore the whole schema space in a recursive descent approach.
  • the Alphabetical list view is for those who are already familiar with the overall structure and concepts. As the name implies one can select from an alphabetical list of elements.

Comments and questions
Please address comments and questions concerning this documentation via either the website Sumex1 or the email address info@sumex1.net


Sumex1

Sumex1

The SUMEX1 project is a sweeping joint industry initiative of SUVA. The project provides various middleware ATL COM modules -all based on an open modular architectural blueprint- usable in software of the Swiss healthcare sector. It is the intent of SUVA to help software developers and last but not least the Swiss healthcare providers mastering the complexity of e.g. the TarMed tariff system and easily overcoming the obstacles of the electronic billing.

You may use all Sumex1 COM modules as a part of your software application product free of charge. By using such a COM module there is no necessity to develop validation services, electronic invoicing and OCR-capable printing in your own software application product or other primary services for which the Sumex1 COM module was intended for. These Sumex1 COM modules improve your software application product by performing a higher quality communication between your clients and the health care insurance companies. There is a EULA accompanying each installer of a Sumex1 COM module, that lays the juristic foundation of the usage e.g. the EULA of the tarmedValidator.

SUVA as copyright holder and principal maintainers of the software have the very intention to supply state of the art modules that benefits all partners in the Swiss healthcare sector. You can trust our willingness to keep that project alive - in fact, the past 15 years should be proof enough!


Copyright (©) notice

Copyright (©) notice

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and this schema file is not altered. The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.


Purpose of the schema file

Purpose of the schema file

This is the schema definition for a nursing "Care Credit Request" (CCR) process encoded in XML. The content is a planning record dataset of a nursing institution that basically defines the required input to a possible CCR grouper. Furthermore, the incurred costs are defined by a set of tariff based service records. To fully document the cost relation the planning records are linked to the corresponding service records.

The careCreditRequest is generated by a nursing care provider and then sent to the designated debitor. The subchapter Purpose/Anatomy of a request provides a broad overview about the building blocks of a request.

Each individual request is defined by a unique triple of data denoted as object reference. The subchapter Purpose/Object reference provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference".

Besides the topmost object reference the XML request is further specified by a set of process attributes, namely

  • the optional copy attribute defining the XML request as an identical copy of an initial request.
  • the optional storno attribute basically canceling the XML request defined by the topmost object reference.
The copy and storno attributes can be combined to form a total of 4 different combinations. The subchapter Purpose/Process attributes provides an in-depth description of these attributes.

Upon receiving the XML request the recipient can respond by [0,n] nursing "Care Credit Response" messages, whereas the content per definition defines an answer to the topmost object reference - and only to that object!

This XML project is normative for the electronic nursing CCR process in Switzerland.


Conventions, terms, and definitions used

Conventions, terms, and definitions used

This paragraph describes the conventions, terms, and definitions used in the documentation of the XSD schema files. It is assumed that the reader has at least a basic understanding of XSD schemas. Therefore, if there is an ambiguous description or insufficient documentation regarding the XSD schemas itself, you need to look up the official XSD schema definitions at W3C at http://www.w3c.org, this is especially true when using the signature and encryption mechanism.

Character entities
Since some characters in a XML infoset are forbidden these characters must be encoded via character entities. The table shows these special characters and their character entity counterparts.
& => &amp;
' => &apos;
> => &gt;
< => &lt;
" => &quot;

Basic XSD data types used
boolean | boolean has the value space required to support the mathematical concept of binary-valued logic: {true, false}. An instance of a data type that is defined as boolean can have the following legal literal value {true, false, 1, 0}.
double | The double data type corresponds to IEEE double-precision 64-bit floating point type [IEEE 754-1985]. The basic value space of double consists of the values m x 2^e, where m is an integer whose absolute value is less than 2^53, and e is an integer between -1075 and 970, inclusive.
enumeration | enumeration constrains the value space to a specified set of values.
int | int is derived from a 32bit integer by setting the value of maxInclusive and minInclusive to be 2147483647 and -2147483648.
NMTOKEN | NMTOKEN represents a token concept. The value space of NMTOKEN is the set of tokens (strings) that match the production.
pattern | pattern is a constraint on the value space of a data type, which is achieved by constraining the lexical space to literals, which match a specific pattern. The value of pattern must be a regular expression.
string | The string data type represents character strings. The value space of string is the set of finite-length sequences of characters. A character is an atomic unit of communication.


Anatomy of a request

Anatomy of a request

The following figure shows the various building blocks, their meanings and dependencies on each other, that eventually form a request.
The building block processing is a container for processing instructions e.g. transport routing.
The building block payload is the container that holds the explicit data.
The building block for reference objects
The building block body is the data container. If encryption is used the container body is the target and will be replaced by the encrypted data xenc:EncryptedData
The building block ds:Signature holds the Signature data, whereas the container payload defines the signed part
Please note, that from a principle point of view these building blocks apart from processing are once generated unchangeable. Since the intermediate must include routing information or external institutions must validate the data, the processing block is outside the signature and encryption area and thus changeable.


Object reference,...

Object reference, ...

The following paragraphs define the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request is defined by such an object reference. All XML responses must copy the object reference from the request, thus the object reference is a clustered primary key!

object reference chain

As a consequence of the schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "General Invoice Request" can hold a maximum of 2 object references, namely
  • an optional credit object reference from a former "General Credit Request" process
  • a mandatory invoice object reference from the initial "General Invoice Request" process
whereas a "Care Credit Request" just has 1 object reference, namely
  • a mandatory credit object reference from the "Care Credit Request" process
The set of object references by itself defines an ordered object reference chain (e.g. credit -> invoice) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference and only for that.


Process attributes

Process attributes

An XML request is primarily defined by its topmost object reference (see Purpose::Object reference). However, the XML request is further characterized by a state that is formed by a set of Boolean process attributes, namely

copy attribute

The copy attribute defines the XML request as an identical copy of an initial request.
The absence of the copy attribute in reverse defines the XML request as "normal" (initial) request.

It is considered an error to send a XML request with turned on copy attribute without having prior sent a "normal" request.

storno attribute

The storno attribute cancels the XML request defined by the topmost reference object.
The absence of the storno attribute in reverse defines the XML request as "normal" request.

It is considered an error to send a XML request with turned on storno attribute without having prior sent a "normal" request.

The copy and storno attributes can be combined to form a total of 4 different combinations.


Notes about the signature

Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects
  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.
    sender is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute.
  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/ccr:request/ccr:payload)">
  • The signature algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-1
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization
  • it is recommended to add the public key via the X509Data element such that a key store can be built at the recipient's site.

As an example the Signature element looks like
<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">>
 <SignedInfo>
  <CanonicalizationMethod Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#"/>
  <SignatureMethod Algorithm="http://www.w3.org/2000/09/xmldsig#rsa-sha1"/>
  <Reference URI="#xpointer(/credit:request/credit:payload)">
   <DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1"/>
   <DigestValue>...</DigestValue>
  </Reference>
 </SignedInfo>
 <SignatureValue>...</SignatureValue>
 <KeyInfo>
  <X509Data>
  <X509Certificate>...</X509Certificate>
  </X509Data>
 </KeyInfo>
</Signature>


Notes about the encryption

Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.
XML Encryption uses the KeyInfo element, which appears as the child of a EncryptedData element and provides information to a recipient about what keying material to use in decrypting encrypted data.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects
  • The encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.
    recipient is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute
  • The used X509 certificate for encryption must be the one with the highest serial number received by the counterpart XML so far.
    This allows for a seamless transfer to new certificates.
  • W3C's namespace http://www.w3.org/2001/04/xmlenc must be used- cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to Triple DES
  • It is highly recommended to supply a comma separated serialization of the issuer (in X509 canonical form) and serial number of the public certificate in the <KeyName> element. This allows the recipient to identify the used public certificate prior the decryption process.
    This information becomes essential as soon as the validity of one certificate is running out and a new one is propagated.

As an example the EncryptedData element looks like
<EncryptedData xmlns="http://www.w3.org/2001/04/xmlenc#" Type="http://www.w3.org/2001/04/xmlenc#Element">
 <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#tripledes-cbc"/>
 <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
  <EncryptedKey xmlns="http://www.w3.org/2001/04/xmlenc#">
   <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#rsa-1_5"/>
   <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
    <KeyName>C=CH, S=ZH, L=Zurich, O=Health Insurance Company, OU=HI Manager App, serial=4E55FF58</KeyName>
   </KeyInfo>
   <CipherData>
    <CipherValue>...</CipherValue>
   </CipherData>
  </EncryptedKey>
 </KeyInfo>
 <CipherData>
  <CipherValue>...</CipherValue>
 </CipherData>
</EncryptedData>


Sequence of Sign & Crypt...

Sequence of Sign & Crypt...

The signature and encryption boundary conditions are in detail documented in the subchapters «Purpose::Signature» and «Purpose::Encryption».
However, if both the signature and encryption processes are applied to a XML infoset it is of uttermost importance to apply the correct sequence of operation.

Sequence of operation
  1. the signature process is applied to the raw XML infoset
  2. the encryption process is applied to the signed XML infoset
Of course, the sequence of operation is reversed when a signed and encrypted XML infoset is loaded.
This sequence is required and must be obeyed otherwise the
decryption and the check of the signature validity is at risk!


Preamble of schema file

Preamble of schema file

The preamble of the schema file is defined as follows:
<schema targetNamespace="http://sumex1.net/ccr"
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:ccr="http://sumex1.net/ccr"
        elementFormDefault="qualified" attributeFormDefault="unqualified">
From this definition it is evident that all elements must be qualified that is defined with the namespace tag ccr followed by the element name. Furthermore, the target namespace and the specific namespace ccr maps to http://sumex1.net/ccr.
The xenc and ds namespaces are used by the encryption and signature elements which can optionally be used in an infoset.

Therefore, to define a correct XML infoset the elements must be defined like the following XML code snippet (for german as data language):
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<ccr:request xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:ccr="http://sumex1.net/ccr"
        xmlns="http://sumex1.net/ccr"
        xsi:schemaLocation="http://sumex1.net/ccr careCreditRequest_450.xsd"
        language="de" modus="production" validation_status="0" >
XML elements go here...

 </ccr:request>


Hierarchical list of used XSD definitions

Hierarchical list of used XSD definitions

The following subchapters list all XSD definitions of the schema in hierarchical order going from the topmost element request down as the appropriate definition is encountered.


element request

Annotation The request element is the root of the careCreditRequest process.
The request is divided into 2 parts
  • the processing element supplies the necessary data for the transport
  • the payload element supplies the CCR data
diagram
namespace | http://sumex1.net/ccr
type | ccr:requestType
properties
content complex
children | ccr:processing ccr:payload ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
validation_status | long
attributes annotations
Name | Notes
language | language defines the used data language (name of the services etc.) encoded by a terminal set of ISO language specifiers.
modus | modus defines the operating modus encoded by a terminal set of tokens
validation_status validation_status defines the validity status of XML infoset after the infoset is generated and validated by a DOM. 0 or absence of the attribute means OK.
It is possible to knowingly encode an XML infoset that is not well formed or invalid regarding its content. validation_status then signals an error condition to the recipient.
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus | NMTOKEN | test | the modus test is for software developers to test the processing.
source | <element name="request" type="ccr:requestType"/>


element requestType/processing

Annotation | The processing element is a container for processing instructions at an intermediate's site (e.g. transport routing).
diagram
namespace | http://sumex1.net/ccr
type | ccr:processingType
properties
isRef | 0
content | complex
children | ccr:transport
source | <element name="processing" type="ccr:processingType"/>


element processingType/transport

Annotation | The transport element defines the routing of the infoset going from a sender party over any number of intermediates to a receiver party. All the involved parties are defined by Global Location Numbers (GLN) as defined by RefData
diagram
namespace | http://sumex1.net/ccr
type | ccr:transportType
properties
isRef | 0
content | complex
children | ccr:via
attributes parameters
Name | Type | Use | Default | Fixed
from | ccr:eanPartyType | required
to | ccr:eanPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the infoset to the first intermediate
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the infoset from the last intermediate.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source | <element name="transport" type="ccr:transportType"/>


element transportType/via

Annotation The via element defines one intermediate hop through which the infoset was routed.
It is in the responsibility of an intermediate to correctly add a further via element if this intermediate has to route the infoset to another intermediate instead of deliver to the recipient.
diagram
namespace http://sumex1.net/ccr
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
via | ccr:eanPartyType | required
sequence_id | unsignedShort | required
attributes annotations
Name | Notes
via | via is the GLN of an intermediate
sequence_id | sequence_id is a sequence number starting with 1 that defines a certain intermediate hop. In each new via element the sequence number is increased by 1 thus forming a chain of intermediate hops
source <element name="via" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="ccr:eanPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>


element requestType/payload

Annotation | The payload element supplies the CCR data and will not be altered in the transport process. The payload can optionally be signed by at W3C signing process.
diagram
namespace | http://sumex1.net/ccr
type | ccr:payloadType
properties
isRef | 0
content | complex
children | ccr:credit_ref ccr:credit ccr:body xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
storno | boolean | false
copy | boolean | false
attributes annotations
Name | Notes
storno | storno augments the CCR reference object by a storno command that is the CCR reference object is an identical clone (except for the storno attribute) of a prior sent request.
copy | copy augments the CCR reference object by a copy command that is the CCR reference object is an identical clone (except for the copy attribute) of a prior sent request.
source | <element name="payload" type="ccr:payloadType"/>


element payloadType/credit_ref

Annotation The credit_ref element defines a former credit object reference to which the current credit reference object is logically linked. There are 4 situations where such a credit object reference should be supplied:
  1. The current ordinance type is followup: the credit_ref element defines the last accepted credit object request - either the first or followup ordinance.
  2. The current ordinance type is modification: the credit_ref element defines the rejected credit object request.
  3. The current ordinance type is re-consideration: the credit_ref element defines the rejected credit object request.
  4. The current ordinance type is transient: the credit_ref element defines the main credit object request - either the first or followup ordinance.
There is no need to define a credit_ref element if the credit type is first since there is per definition no reference to a former credit request.
diagram
namespace | http://sumex1.net/ccr
type | ccr:creditType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | ccr:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the credit's infoset generation
This is one of 3 identifiers that form the credit object reference. request_timestamp will be generated once for a certain credit object reference and thereafter always referenced!
request_date request_date is the main software's date of the credit request ("Kostenvoranschlagdatum")
This is one of 3 identifiers that form the credit object reference. request_date must be identical for the same credit object reference!
request_id request_id is the main software's ID of the credit request ("Kostenvoranschlagnummer")
This is one of 3 identifiers that form the credit object reference. request_id must be identical for the same credit object reference!
source | <element name="credit_ref" type="ccr:creditType" minOccurs="0"/>


element payloadType/credit

Annotation The credit element defines the unique credit reference object for which the care credit request (CCR) is produced.
This object is firstly produced when generating the original CCR. Any further processing (sending a copy or canceling the CCR) references this same reference object unaltered!
diagram
namespace | http://sumex1.net/ccr
type | ccr:creditType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | ccr:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the credit's infoset generation
This is one of 3 identifiers that form the credit object reference. request_timestamp will be generated once for a certain credit object reference and thereafter always referenced!
request_date request_date is the main software's date of the credit request ("Kostenvoranschlagdatum")
This is one of 3 identifiers that form the credit object reference. request_date must be identical for the same credit object reference!
request_id request_id is the main software's ID of the credit request ("Kostenvoranschlagnummer")
This is one of 3 identifiers that form the credit object reference. request_id must be identical for the same credit object reference!
source | <element name="credit" type="ccr:creditType"/>


element payloadType/body

Annotation | The body element contains all the highly sensitive CCR data (data privacy relevant). Therefore the body element can be replaced by the encrypted counterpart xenc:EncryptedData
diagram
namespace | http://sumex1.net/ccr
type | ccr:bodyType
properties
isRef | 0
content | complex
children | ccr:prolog ccr:remark ccr:biller ccr:provider ccr:additional_provider ccr:insurance ccr:debitor ccr:referrer ccr:patient ccr:planning_data ccr:documents
source | <element name="body" type="ccr:bodyType"/>


element bodyType/prolog

Annotation | The prolog element is a container that holds information about all involved software that eventually generated the infoset (XML generator, possibly used validators, and main software).
diagram
namespace | http://sumex1.net/ccr
type | ccr:prologType
properties
isRef | 0
content | complex
children | ccr:package ccr:generator
source | <element name="prolog" type="ccr:prologType"/>


element prologType/package

Annotation | The package element defines the main software that supplies all data for the infoset
diagram
namespace | http://sumex1.net/ccr
type | ccr:softwareType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | ccr:stringType1_50 | required
copyright | ccr:stringType1_50
description | ccr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="package" type="ccr:softwareType" minOccurs="0"/>


element softwareType/depends_on

Annotation The depends_on element defines a dependence upon a further software/module.
The dependence chain allows the definition of all involved software/modules that participated in the generation process.
diagram
namespace | http://sumex1.net/ccr
type | ccr:dependsOnType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | ccr:stringType1_50 | required
copyright | ccr:stringType1_50
description | ccr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source | <element name="depends_on" type="ccr:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>


element prologType/generator

Annotation The generator element defines the infoset generator.
It is assumed that there is an architectural distinction between package (main software) and generator like in a Sumex1 environment. If this is not the case then just define the same data here as in the package element.
diagram
namespace | http://sumex1.net/ccr
type | ccr:softwareType
properties
isRef | 0
content | complex
children | ccr:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | ccr:stringType1_50 | required
copyright | ccr:stringType1_50
description | ccr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="generator" type="ccr:softwareType"/>


element bodyType/remark

Annotation | The remark element supplies an optional remark for the CCR
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_350
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 350
source | <element name="remark" type="ccr:stringType1_350" minOccurs="0"/>


element bodyType/biller

Annotation | The biller element defines the biller of the corresponding invoice
diagram
namespace | http://sumex1.net/ccr
type | ccr:billerAddressType
properties
isRef | 0
content | complex
children | ccr:company ccr:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
zsr | ccr:zsrPartyType
specialty | ccr:stringType1_350
uid_number | ccr:stringType1_15
attributes annotations
Name | Notes
ean_party | ean_party is the biller's GLN as defined by RefData
zsr | zsr is the biller's ZSR (KSK) as defined by Santésuisse
specialty | specialty is the biller's specialty (branch of medical science a medical person practices)
uid_number uid_number is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789
source | <element name="biller" type="ccr:billerAddressType"/>


element billerAddressType/company

Annotation | The biller is a company given by the company element
diagram
namespace | http://sumex1.net/ccr
type | ccr:companyType
properties
isRef | 0
content | complex
children | ccr:companyname ccr:department ccr:subaddressing ccr:postal ccr:telecom ccr:online
source | <element name="company" type="ccr:companyType"/>


element companyType/companyname

Annotation | The companyname element supplies the name of a company
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="companyname" type="ccr:stringType1_35"/>


element companyType/department

Annotation | The department element supplies the name of a the involved department of a company
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="department" type="ccr:stringType1_35" minOccurs="0"/>


element companyType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="ccr:stringType1_35" minOccurs="0"/>


element companyType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://sumex1.net/ccr
type | ccr:postalAddressType
properties
isRef | 0
content | complex
children | ccr:pobox ccr:street ccr:zip ccr:city
source | <element name="postal" type="ccr:postalAddressType"/>


element postalAddressType/pobox

Annotation | The pobox element supplies the post office box part of the postal address
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="pobox" type="ccr:stringType1_35" minOccurs="0"/>


element postalAddressType/street

Annotation | The street element supplies the street part of the postal address
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="street" type="ccr:stringType1_35" minOccurs="0"/>


element postalAddressType/zip

Annotation | The zip element supplies the zip part of the postal address
diagram
namespace | http://sumex1.net/ccr
type | ccr:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | ccr:stringType1_9
countrycode | ccr:stringType1_3 | CH
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
source | <element name="zip" type="ccr:zipType"/>


element postalAddressType/city

Annotation | The city element supplies the city part of the postal address
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="city" type="ccr:stringType1_35"/>


element companyType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://sumex1.net/ccr
type | ccr:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:phone ccr:fax
source | <element name="telecom" type="ccr:telecomAddressType" minOccurs="0"/>


element telecomAddressType/phone

Annotation | The phone element supplies a telephone number (either landline or mobile)
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_25
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="phone" type="ccr:stringType1_25" maxOccurs="3"/>


element telecomAddressType/fax

Annotation | The fax element supplies a telefax number
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_25
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="fax" type="ccr:stringType1_25" minOccurs="0" maxOccurs="3"/>


element companyType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://sumex1.net/ccr
type | ccr:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:email ccr:url
source | <element name="online" type="ccr:onlineAddressType" minOccurs="0"/>


element onlineAddressType/email

Annotation | The email element supplies an email address
diagram
namespace | http://sumex1.net/ccr
type | restriction of ccr:stringType1_70
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 70
pattern .+@.+
source <element name="email" maxOccurs="3">
<simpleType>
<restriction base="ccr:stringType1_70">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>


element onlineAddressType/url

Annotation | The url element supplies any URI defined address (e.g. a homepage, facebook or twitter account etc.)
diagram
namespace | http://sumex1.net/ccr
type | restriction of anyURI
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 100
source <element name="url" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>
</element>


element billerAddressType/person

Annotation | The biller is a person given by the person element
diagram
namespace | http://sumex1.net/ccr
type | ccr:personType
properties
isRef | 0
content | complex
children | ccr:familyname ccr:givenname ccr:subaddressing ccr:postal ccr:telecom ccr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | ccr:stringType1_35
title | ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="ccr:personType"/>


element personType/familyname

Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="ccr:stringType1_35"/>


element personType/givenname

Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="ccr:stringType1_35"/>


element personType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://sumex1.net/ccr
type | ccr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="ccr:stringType1_35" minOccurs="0"/>


element personType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://sumex1.net/ccr
type | ccr:postalAddressType
properties
isRef | 0
content | complex
children | ccr:pobox ccr:street ccr:zip ccr:city
source | <element name="postal" type="ccr:postalAddressType"/>


element personType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://sumex1.net/ccr
type | ccr:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:phone ccr:fax
source | <element name="telecom" type="ccr:telecomAddressType" minOccurs="0"/>


element personType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://sumex1.net/ccr
type | ccr:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:email ccr:url
source | <element name="online" type="ccr:onlineAddressType" minOccurs="0"/>


element bodyType/provider

Annotation | The provider element is the provider of the CCR data
diagram
namespace | http://sumex1.net/ccr
type | ccr:providerAddressType
properties
isRef | 0
content | complex
children | ccr:company ccr:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
zsr | ccr:zsrPartyType
specialty | ccr:stringType1_350
attributes annotations
Name | Notes
ean_party | ean_party is the provider's GLN as defined by RefData
zsr | zsr is the provider's ZSR (KSK) as defined by Santésuisse
specialty | specialty is the provider's specialty (branch of medical science a doctor practices)
source | <element name="provider" type="ccr:providerAddressType"/>


element providerAddressType/company

Annotation | The provider is a company given by the company element
diagram
namespace | http://sumex1.net/ccr
type | ccr:companyType
properties
isRef | 0
content | complex
children | ccr:companyname ccr:department ccr:subaddressing ccr:postal ccr:telecom ccr:online
source | <element name="company" type="ccr:companyType"/>


element providerAddressType/person

Annotation | The provider is a person given by the person element
diagram
namespace | http://sumex1.net/ccr
type | ccr:personType
properties
isRef | 0
content | complex
children | ccr:familyname ccr:givenname ccr:subaddressing ccr:postal ccr:telecom ccr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | ccr:stringType1_35
title | ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="ccr:personType"/>


element bodyType/additional_provider

Annotation | The optional additional_provider element set defines alternative providers, who are taking over part or all of the planned treatment, should the primary provider be indisposed or hindered from doing so.
diagram
namespace | http://sumex1.net/ccr
type | ccr:providerAddressType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
children | ccr:company ccr:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
zsr | ccr:zsrPartyType
specialty | ccr:stringType1_350
attributes annotations
Name | Notes
ean_party | ean_party is the provider's GLN as defined by RefData
zsr | zsr is the provider's ZSR (KSK) as defined by Santésuisse
specialty | specialty is the provider's specialty (branch of medical science a doctor practices)
source | <element name="additional_provider" type="ccr:providerAddressType" minOccurs="0" maxOccurs="unbounded"/>


element bodyType/insurance

Annotation | The insurance element is the insurance that is the final recipient of the request
diagram
namespace | http://sumex1.net/ccr
type | ccr:insuranceAddressType
properties
isRef | 0
content | complex
children | ccr:company ccr:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
attributes annotations
Name | Notes
ean_party | ean_party is the insurance's GLN as defined by RefData
source | <element name="insurance" type="ccr:insuranceAddressType"/>


element insuranceAddressType/company

Annotation | The insurance is a company given by the company element
diagram
namespace | http://sumex1.net/ccr
type | ccr:companyType
properties
isRef | 0
content | complex
children | ccr:companyname ccr:department ccr:subaddressing ccr:postal ccr:telecom ccr:online
source | <element name="company" type="ccr:companyType"/>


element insuranceAddressType/person

Annotation | The insurance is a person given by the person element
diagram
namespace | http://sumex1.net/ccr
type | ccr:personType
properties
isRef | 0
content | complex
children | ccr:familyname ccr:givenname ccr:subaddressing ccr:postal ccr:telecom ccr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | ccr:stringType1_35
title | ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="ccr:personType"/>


element bodyType/debitor

Annotation
diagram
namespace | http://sumex1.net/ccr
type | ccr:debitorAddressType
properties
isRef | 0
content | complex
children | ccr:company ccr:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
attributes annotations
Name Notes
ean_party ean_party is the debitor's GLN number as defined by RefData
Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
source | <element name="debitor" type="ccr:debitorAddressType"/>


element debitorAddressType/company

Annotation | The debitor is a legal entity defined by a company address element
diagram
namespace | http://sumex1.net/ccr
type | ccr:companyType
properties
isRef | 0
content | complex
children | ccr:companyname ccr:department ccr:subaddressing ccr:postal ccr:telecom ccr:online
source | <element name="company" type="ccr:companyType"/>


element debitorAddressType/person

Annotation | The debitor is a natural person defined by the person address element
diagram
namespace | http://sumex1.net/ccr
type | ccr:personType
properties
isRef | 0
content | complex
children | ccr:familyname ccr:givenname ccr:subaddressing ccr:postal ccr:telecom ccr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | ccr:stringType1_35
title | ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="ccr:personType"/>


element bodyType/referrer

Annotation The optional referrer address element defines an referrer who is the patient's principle medical provider.
Note, that this might be the patient's general practitioner in case of an ambulatory treatment or a ward practitioner in the case of a stationary treatment.
diagram
namespace | http://sumex1.net/ccr
type | ccr:referrerAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:company ccr:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType
zsr | ccr:zsrPartyType
specialty | ccr:stringType1_350
attributes annotations
Name | Notes
ean_party | ean_party is the referrer's GLN as defined by RefData
zsr | zsr is the referrer's ZSR as defined by Santésuisse
specialty | specialty is the referrer's medical specialty (branch of medical science a doctor practices)
source | <element name="referrer" type="ccr:referrerAddressType" minOccurs="0"/>


element referrerAddressType/company

Annotation | The referrer is a legal entity defined by a company address element
diagram
namespace | http://sumex1.net/ccr
type | ccr:companyType
properties
isRef | 0
content | complex
children | ccr:companyname ccr:department ccr:subaddressing ccr:postal ccr:telecom ccr:online
source | <element name="company" type="ccr:companyType"/>


element referrerAddressType/person

Annotation | The referrer is a natural person defined by the person address element
diagram
namespace | http://sumex1.net/ccr
type | ccr:personType
properties
isRef | 0
content | complex
children | ccr:familyname ccr:givenname ccr:subaddressing ccr:postal ccr:telecom ccr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | ccr:stringType1_35
title | ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="ccr:personType"/>


element bodyType/patient

Annotation | The patient element defines the anonymized patient relevant data for the CCR
diagram
namespace | http://sumex1.net/ccr
type | ccr:patientAddressType
properties
isRef | 0
content | complex
children | ccr:person ccr:card
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn | ccr:ssnPartyType
disability_allowance | derived by: NMTOKEN | none
incontinence_degree | derived by: NMTOKEN | none
attributes annotations
Name | Notes
gender | gender defines the gender encoded by a terminal set of tokens
birthdate | birthdate defines the birthdate of the patient
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
disability_allowance | disability_allowance defines the degree of disability allowance gender encoded by a terminal set of tokens
incontinence_degree | incontinence_degree defines the degree of incontinence encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
disability_allowance | NMTOKEN | none | the degree of disability allowance is none
disability_allowance | NMTOKEN | low | the degree of disability allowance is low
disability_allowance | NMTOKEN | medium | the degree of disability allowance is medium
disability_allowance | NMTOKEN | high | the degree of disability allowance is high
gender | NMTOKEN | male | the gender is male
gender | NMTOKEN | female | the gender is female
incontinence_degree | NMTOKEN | none | the degree of incontinence is none
incontinence_degree | NMTOKEN | low | the degree of incontinence is low
incontinence_degree | NMTOKEN | medium | the degree of incontinence is medium
incontinence_degree | NMTOKEN | high | the degree of incontinence is high
source | <element name="patient" type="ccr:patientAddressType"/>


element patientAddressType/person

Annotation | The patient's address given by the person element
diagram
namespace | http://sumex1.net/ccr
type | ccr:personType
properties
isRef | 0
content | complex
children | ccr:familyname ccr:givenname ccr:subaddressing ccr:postal ccr:telecom ccr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | ccr:stringType1_35
title | ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="ccr:personType"/>


element patientAddressType/card

Annotation | The card element is a container for information about the patient's insurance card
diagram
namespace | http://sumex1.net/ccr
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
card_id | ccr:stringType1_35 | required
expiry_date | dateTime
validation_date | dateTime
validation_id ccr:stringType1_35
validation_server ccr:stringType1_35
attributes annotations
Name | Notes
card_id | card_id is the unique 20 digits card identifier
expiry_date | expiry_date is the expiry date of the card
validation_date | validation_date is the date of the last validation of the card's data
validation_id | validation_id is the replied id of the last validation of the card's data
validation_server | validation_server is the used server for the last validation process
source <element name="card" minOccurs="0">
<complexType>
<attribute name="card_id" type="ccr:stringType1_35" use="required"/>
<attribute name="expiry_date" type="dateTime"/>
<attribute name="validation_date" type="dateTime"/>
<attribute name="validation_id" type="ccr:stringType1_35"/>
<attribute name="validation_server" type="ccr:stringType1_35"/>
</complexType>
</element>


element bodyType/planning_data

Annotation | The planning_data element is a container grouping all data specific for the nursing service planning set.
diagram
namespace | http://sumex1.net/ccr
type | ccr:planningDataType
properties
isRef | 0
content | complex
children | ccr:kvg ccr:vvg ccr:uvg ccr:ivg ccr:mvg ccr:org ccr:treatment ccr:postpartum_care ccr:home_care ccr:nursinghome_care ccr:planning_records ccr:service_records
attributes parameters
Name | Type | Use | Default | Fixed
ordinance_type | derived by: NMTOKEN | first
provider_number | positiveInteger | 4
attributes annotations
Name | Notes
ordinance_type | ordinance_type defines the type of ordinance request encoded by a terminal set of tokens
provider_number provider_number is a qualification number of the care provider.
Currently the are 2 distinct values defined and recognized, namely
  • provider_number=4 aka home care organisation
  • provider_number=5 aka nursing home organisation
attributes enumerations
Name | Extension | Base | Value | Annotations
ordinance_type | NMTOKEN | first | the ordinance is of type first - an initial ordinance request
ordinance_type | NMTOKEN | followup | the ordinance is of type followup - a followup ordinance request following the first ordinance
ordinance_type | NMTOKEN | modification | the ordinance is of type modification - an ordinance request whose data space is modified regarding a previously sent but rejected ordinance
ordinance_type | NMTOKEN | re-consideration | the ordinance is of type re-consideration - an ordinance request whose data space is unmodified but possibly extended by further documents and is sent for a re-consideration at the recipient's site.
ordinance_type | NMTOKEN | transient | the ordinance is of type transient - a transient ordinance request defining a transient care situation for a limited and foreseeable time.
source | <element name="planning_data" type="ccr:planningDataType"/>


element planningDataType/kvg

Annotation | The kvg element defines the applicable law as KVG ("Krankenversicherungsgesetz")
diagram
namespace | http://sumex1.net/ccr
type | ccr:kvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | ccr:stringType1_35
case_id | ccr:stringType1_35
case_date | dateTime
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
source | <element name="kvg" type="ccr:kvgLawType"/>


element planningDataType/vvg

Annotation | The vvg element defines the applicable law as VVG ("Versicherungsvertragsgesetz")
diagram
namespace | http://sumex1.net/ccr
type | ccr:vvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | ccr:stringType1_35
case_id | ccr:stringType1_35
case_date | dateTime
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
source | <element name="vvg" type="ccr:vvgLawType"/>


element planningDataType/uvg

Annotation | The uvg element defines the applicable law as UVG ("Unfallversicherungsgesetz")
diagram
namespace | http://sumex1.net/ccr
type | ccr:uvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | ccr:stringType1_35
case_id | ccr:stringType1_35
case_date | dateTime
ssn | ccr:ssnPartyType
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance,
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
source | <element name="uvg" type="ccr:uvgLawType"/>


element planningDataType/ivg

Annotation | The ivg element defines the applicable law as IVG ("Invalidenversicherungsgesetz")
diagram
namespace | http://sumex1.net/ccr
type | ccr:ivgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
case_id | derived by: string | required
case_date | dateTime
ssn | ccr:ssnPartyType | required
nif | ccr:nifPartyType
attributes annotations
Name | Notes
case_id | case_id is the treatment/case identification given by the insurance (order number)
case_date | case_date is the treatment/case date given by the insurance (order date)
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
nif | nif is the IV specific identification number for the provider.
source | <element name="ivg" type="ccr:ivgLawType"/>


element planningDataType/mvg

Annotation | The mvg element defines the applicable law as MVG ("Militäversicherungsgesetz")
diagram
namespace | http://sumex1.net/ccr
type | ccr:mvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | ccr:stringType1_35
case_id | ccr:stringType1_35
case_date | dateTime
ssn | ccr:ssnPartyType | required
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
source | <element name="mvg" type="ccr:mvgLawType"/>


element planningDataType/org

Annotation | The org element defines the applicable law as ORG ("Obligationenrecht")
diagram
namespace | http://sumex1.net/ccr
type | ccr:orgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | ccr:stringType1_35
case_id | ccr:stringType1_35
case_date | dateTime
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance,
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
source | <element name="org" type="ccr:orgLawType"/>


element planningDataType/treatment

Annotation | The treatment element supplies data about the planned and planning defined treatment period.
diagram
namespace | http://sumex1.net/ccr
type | ccr:treatmentType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required
date_end | dateTime | required
treatment_days | duration | required
treatment_canton | derived by: NMTOKEN | required
treatment_type | derived by: NMTOKEN | ambulatory
treatment_reason | derived by: NMTOKEN | required
tiers_mode | derived by: NMTOKEN | TP
attributes annotations
Name | Notes
date_begin | date_begin is the start of the planned and planning defined treatment period.
date_end | date_end is the end of the planned and planning defined treatment period.
treatment_days | treatment_days is the number of planned treatment days within the given treatment period.
treatment_canton treatment_canton is Swiss canton or a country close to the border in which the treatment is taking place encoded by a terminal set of tokens.
Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations. Liechtenstein is coded by "LI" as in the prior standards.
treatment_type | treatment_type is the principle type of treatment encoded by a terminal set of tokens.
treatment_reason | treatment_reason is the primary reason why the treatment is taking place encoded by a terminal set of tokens
tiers_mode | tiers_mode is the principle mode of tiers encoded by a terminal set of tokens.
attributes enumerations
Name | Extension | Base | Value | Annotations
tiers_mode | NMTOKEN | TP | the tiers mode is TP aka Tiers Payant (default)
tiers_mode | NMTOKEN | TG | the tiers mode is TG aka Tiers Garant
treatment_canton | NMTOKEN | AG | the canton is AG - Aargau
treatment_canton | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
treatment_canton | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
treatment_canton | NMTOKEN | BE | the canton is BE - Bern
treatment_canton | NMTOKEN | BL | the canton is BL - Baselland
treatment_canton | NMTOKEN | BS | the canton is BS - Basel
treatment_canton | NMTOKEN | FR | the canton is FR - Fribourg
treatment_canton | NMTOKEN | GE | the canton is GE - Geneva
treatment_canton | NMTOKEN | GL | the canton is GL - Glarus
treatment_canton | NMTOKEN | GR | the canton is GR - Graubünden
treatment_canton | NMTOKEN | JU | the canton is JU - Jura
treatment_canton | NMTOKEN | LU | the canton is LU - Lucerne
treatment_canton | NMTOKEN | NE | the canton is NE - Neuchâtel
treatment_canton | NMTOKEN | NW | the canton is NW - Nidwalden
treatment_canton | NMTOKEN | OW | the canton is OW - Obwalden
treatment_canton | NMTOKEN | SG | the canton is SG - St. Gallen
treatment_canton | NMTOKEN | SH | the canton is SH - Schaffhausen
treatment_canton | NMTOKEN | SO | the canton is SO - Solothurn
treatment_canton | NMTOKEN | SZ | the canton is SZ - Schwyz
treatment_canton | NMTOKEN | TI | the canton is TI - Ticino
treatment_canton | NMTOKEN | TG | the canton is TG - Thurgau
treatment_canton | NMTOKEN | UR | the canton is UR - Uri
treatment_canton | NMTOKEN | VD | the canton is VD - Vaud
treatment_canton | NMTOKEN | VS | the canton is VS - Valais
treatment_canton | NMTOKEN | ZG | the canton is ZG - Zug
treatment_canton | NMTOKEN | ZH | the canton is ZH - Zürich
treatment_canton | NMTOKEN | LI | the country is LI - Liechtenstein
treatment_canton | NMTOKEN | A | the country is A - Austria
treatment_canton | NMTOKEN | D | the country is D - Germany
treatment_canton | NMTOKEN | F | the country is F - France
treatment_canton | NMTOKEN | I | the country is I - Italy
treatment_reason | NMTOKEN | disease | the reason of treatment is a disease
treatment_reason | NMTOKEN | accident | the reason of treatment is an accident
treatment_reason | NMTOKEN | maternity | the reason of treatment is a maternity
treatment_reason | NMTOKEN | prevention | the reason of treatment is prevention
treatment_reason | NMTOKEN | birthdefect | the reason of treatment a birthdefect
treatment_reason | NMTOKEN | unknown | the reason of treatment is unknown (or something not mentioned above)
treatment_type | NMTOKEN | ambulatory | the treatment type is ambulatory (default)
treatment_type | NMTOKEN | stationary | the treatment type is stationary
source | <element name="treatment" type="ccr:treatmentType"/>


element planningDataType/postpartum_care

Annotation | The postpartum_care element supplies requested data about a post partum careing situation given by a home care organisation ("Spitex")
diagram
namespace | http://sumex1.net/ccr
type | ccr:postpartumCareType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
planning_catalog | ccr:stringType1_15 | required
date_of_birth | dateTime | required
domestic_aid_days_per_week | nonNegativeInteger | 0
domestic_aid_hours_per_day | nonNegativeInteger | 0
migel_selfapplication | boolean | false
attributes annotations
Name | Notes
planning_catalog planning_catalog defines the main planning catalog edition.
Note, that the planning_catalog is an unstandardized string consisting of a slash-separated planning catalog name and edition e.g. "RAI-NC/2018" or "BESA/2018".
date_of_birth date_of_birth defines the date and time of a recently born neonate of the patient.
Please note that the birth of the child qualifies the mother for possible home care. Therefore, the date of birth by definition must be close to the date of planned treatment.
domestic_aid_days_per_week | a positive value of the domestic_aid_days_per_week indicates that the patient currently has a household aid the defined days per week. Conversely, a value of 0 means no domestic aid.
domestic_aid_hours_per_day | a positive value of the domestic_aid_hours_per_day indicates that the patient currently has a household aid the defined hours per day. Conversely, a value of 0 means no domestic aid.
migel_selfapplication | migel_selfapplication indicates whether the patient receives MiGel care products for self-application from the home care organisation
source | <element name="postpartum_care" type="ccr:postpartumCareType" minOccurs="0"/>


element planningDataType/home_care

Annotation | The home_care element supplies requested data about an ordinary home careing situation given by a home care organisation ("Spitex")
diagram
namespace | http://sumex1.net/ccr
type | ccr:homeCareType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
planning_catalog | ccr:stringType1_15 | required
stay_daycare_center | boolean | false
domestic_aid_days_per_week | nonNegativeInteger | 0
domestic_aid_hours_per_day | nonNegativeInteger | 0
migel_selfapplication | boolean | false
attributes annotations
Name | Notes
planning_catalog planning_catalog defines the main planning catalog edition.
Note, that the planning_catalog is an unstandardized string consisting of a slash-separated planning catalog name and edition e.g. "RAI-NC/2018" or "BESA/2018".
domestic_aid_days_per_week | a positive value of the domestic_aid_days_per_week indicates that the patient currently has a household aid the defined days per week. Conversely, a value of 0 means no domestic aid.
domestic_aid_hours_per_day | a positive value of the domestic_aid_hours_per_day indicates that the patient currently has a household aid the defined hours per day. Conversely, a value of 0 means no domestic aid.
stay_daycare_center | stay_daycare_center indicates if a patient is staying in a day-care center during daytime.
migel_selfapplication | migel_selfapplication indicates whether the patient receives MiGel care products for self-application from the home care organisation
source | <element name="home_care" type="ccr:homeCareType" minOccurs="0"/>


element planningDataType/nursinghome_care

Annotation | The nursinghome_care element supplies requested data about a nursing home careing situation given by a nursing home organisation
diagram
namespace | http://sumex1.net/ccr
type | ccr:nursinghomeCareType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
planning_catalog | ccr:stringType1_15 | required
care_demand_level | ccr:stringType1_15 | required
assessment_date | dateTime
accommodation_type | positiveInteger | required
attributes annotations
Name Notes
planning_catalog planning_catalog defines the main planning catalog edition.
Note, that the planning_catalog is an unstandardized string consisting of a slash-separated planning catalog name and edition e.g. "RAI-NC/2018" or "BESA/2018".
care_demand_level care_demand_level defines the assed care demand level for the patient.
Note, that the care_demand_level is an unstandardized string consisting of a planning catalog name and care level number e.g. "BESA5" or "PLAISIR3".
assessment_date assessment_date defines the date at which the assessment for the care demand level was performed
Note, that the assessment date is equal or before the treatment start date.
accommodation_type accommodation_typer defines the type of accommodation encodes by an integer number. Currently, there are the following values with a semantic meaning defined, namely
  • accommodation_type=1 aka "long-term stay"
  • accommodation_type=2 aka "short-term stay"
  • accommodation_type=3 aka "person not accommodated"
  • accommodation_type=4 aka "day and night structure"
  • accommodation_type=5 aka "acute and transitional care"
source | <element name="nursinghome_care" type="ccr:nursinghomeCareType" minOccurs="0"/>


element planningDataType/planning_records

Annotation | The planning_records element is container holding the set of all planning_records.
diagram
namespace | http://sumex1.net/ccr
type | ccr:planningRecordsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:planning_record
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines the total number of planning records
source | <element name="planning_records" type="ccr:planningRecordsType" minOccurs="0"/>


element planningRecordsType/planning_record

Annotation | The planning_record element defines one planning record
diagram
namespace | http://sumex1.net/ccr
type | ccr:planningRecordType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required
service_id | derived by: int
catalog_type | ccr:stringType1_15 | required
catalog_code | ccr:stringType1_30 | required
catalog_name | ccr:stringType1_350 | required
quantity | double | required
multiplier_symbol | derived by: string | e
multiplier | double | 1
base_unit | double | required
is_training | boolean | false
corr_unit | double | 0
total_unit | double | required
remark | ccr:stringType1_350
attributes annotations
Name | Notes
record_id | record_id is a record sequence number (starting with 1 and incremented by 1 for each further record) uniquely identifying the record
service_id the optional service_id is a service record pointer that maps the planning record to the corresponding service record that is the planning data is connect the the incurred cost record.
Note that an absent service_id means that no billing portion can be linked to the planning record.
catalog_type | catalog_type is the official planning catalog designator e.g. "RAI-NC", "BESA 5", "KLV7" and the like
catalog_code | catalog_code is the code of the used planning record as defined in the planning catalog
catalog_name | catalog_name is the official name of the planning record as defined in the planning catalog
quantity quantity is the used quantity of the current planning record
Note, that the quantity is defined as double, spanning negative, zero and positive fractional values!
  • negative quantities are used to effectively "subtract" planning records from the grand total
  • a zero quantity is used for "non-billable" and "pro memoria" planning records
  • positive quantities are used for "normal" planning records
quantity must not be rounded but given in full precision.
multiplier_symbol | multiplier_symbol corresponds to a temporal multiplication function that distributes a singular object over the whole treatment interval. The functional behaviour is supplied by a set of (language-dependent) symbols like "t3", "w" etc.
multiplier multiplier is the numerical representation of the multiplier_symbol and defines the multiplication factor that a singular object is distributed over the whole treatment interval.
Please note, that the magnitude of the multiplier might be fractional since an instruction like "t3" might not be transformed integer dependent on the given treatment interval.
base_unit | base_unit defines the base unit of a singular object as defined in the planning catalog
is_training | is_training is a Boolean value that indicates whether the planning record is performed in training mode.
corr_unit corr_value defines an optional correctional unit that is added to the total unit.

Please note, that the sign is significant, i.e. a downscale correction corresponds to a negative value. Furthermore, "corr_value" is an absolute value and is not modulated by "quantity" and "multiplier" (cf. defined equation under "total_unit").

The necessity of a correction depends on the used catalog and is justified in the non-orthogonality of the catalog records.
total_unit total_unit defines the calculated units over the treatment interval as given by the equation:
«( quantity * multiplier * base_unit ) + corr_unit = total_unit »

The equation is calculated in full precision and the result rounded to 2 significant decimal places.
remark | remark is an optional remark for the applied planning record
source | <element name="planning_record" type="ccr:planningRecordType" maxOccurs="unbounded"/>


element planningDataType/service_records

Annotation | The service_records element is container holding the set pure service records that are presumably supplied during the treatment period.
diagram
namespace | http://sumex1.net/ccr
type | ccr:serviceRecordsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:service_record
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines the total number of service records
source | <element name="service_records" type="ccr:serviceRecordsType" minOccurs="0"/>


element serviceRecordsType/service_record

Annotation | The service_record element defines one service record that is tariff catalog based record defining a medical service for a defined price
diagram
namespace | http://sumex1.net/ccr
type | ccr:serviceRecordType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required
tariff_type | derived by: string | required
tariff_code | ccr:stringType1_30 | required
tariff_name | ccr:stringType1_350 | required
quantity | double | required
unit | double | required
unit_factor | derived by: double | 1.0
external_factor | derived by: double | 1.0
amount | double | required
remark | ccr:stringType1_350
attributes annotations
Name | Notes
record_id | record_id is a record sequence number (starting with 1 and incremented by 1 for each further record) uniquely identifying the record
tariff_type | tariff_type is the official 3-character designator of the used tariff as given by Sumex1
tariff_code | tariff_code is the code of the service record as given by the used tariff catalog
tariff_name | tariff_name is the official service name as given by the used tariff catalog
quantity quantity is the used quantity of the current service
Note, that the quantity is defined as double, spanning zero and positive fractional values!
  • a zero quantity is used for "non-billable" and "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)
quantity must not be rounded but given in full precision.
unit unit is the tax point (TP) of the applied service
unit is defined as double and must not be rounded but given in full precision.
unit_factor unit_factor is the tax point value (TPV) of the applied service
unit_factor is defined as double and must not be rounded but given in full precision.
external_factor external_factor is a external scale factor for the applied service
external_factor is used as a measure for giving discounts and can even be zero to supply a charge free service.
amount amount is the charged amount of the applied service
Note, that amount must fulfill the equation:
« quantity * TP * TPV * external_factor = amount»

The equations is calculated in full precision and the result rounded to 2 significant decimal places.
remark | remark is an optional remark for the applied service record
source | <element name="service_record" type="ccr:serviceRecordType" maxOccurs="unbounded"/>


element bodyType/documents

Annotation | The documents element is an optional container for including inline, Base64-coded documents.
diagram
namespace | http://sumex1.net/ccr
type | ccr:documentsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source | <element name="documents" type="ccr:documentsType" minOccurs="0"/>


element documentsType/document

Annotation | The document element defines one physical document of an allowed MIME type that is included in the infoset inline and Base64-coded.
diagram
namespace | http://sumex1.net/ccr
type | ccr:documentType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
children | ccr:base64
attributes parameters
Name | Type | Use | Default | Fixed
title | ccr:stringType1_35 | required
filename | ccr:stringType1_255 | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
title title is the document's title on the primary system and thus describes the document in terms of its semantic content.
A list of possible suggestions -heuristic and incomplete in its nature- can be found at the Sumex1.
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME sniffing.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reduce the allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
source | <element name="document" type="ccr:documentType" maxOccurs="unbounded"/>


element documentType/base64

Annotation | The base64 element defines the document inline and as BASE64-coded octet streams
diagram
namespace | http://sumex1.net/ccr
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="base64" type="base64Binary"/>


element xenc:EncryptedData

Annotation The optional xenc:EncryptedData (as defined by W3C) encrypts and replaces the body element by using the public certificate of the end recipient of this infoset (mostly the insurance).
See the "notes about encryption" in the introduction chapter for further guidance about the encryption.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedDataType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexType payloadType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="EncryptedData" type="xenc:EncryptedDataType"/>


element xenc:EncryptedType/EncryptionMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionMethodType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | xenc:KeySize xenc:OAEPparams
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>


element xenc:EncryptionMethodType/KeySize

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:KeySizeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>


element xenc:EncryptionMethodType/OAEPparams

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="OAEPparams" type="base64Binary" minOccurs="0"/>


element ds:KeyInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyInfoType
properties
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
complexTypes ds:SignatureType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="KeyInfo" type="ds:KeyInfoType"/>


element ds:KeyName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="KeyName" type="string"/>


element ds:KeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyValueType
properties
content | complex
mixed | true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
complexType ds:KeyInfoType
source | <element name="KeyValue" type="ds:KeyValueType"/>


element ds:DSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DSAKeyValueType
properties
content complex
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
complexType ds:KeyValueType
source | <element name="DSAKeyValue" type="ds:DSAKeyValueType"/>


element ds:DSAKeyValueType/P

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="P" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/Q

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Q" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/G

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="G" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Y

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Y" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/J

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="J" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Seed

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Seed" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/PgenCounter

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="PgenCounter" type="ds:CryptoBinary"/>


element ds:RSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RSAKeyValueType
properties
content complex
children | ds:Modulus ds:Exponent
used by
complexType ds:KeyValueType
source | <element name="RSAKeyValue" type="ds:RSAKeyValueType"/>


element ds:RSAKeyValueType/Modulus

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Modulus" type="ds:CryptoBinary"/>


element ds:RSAKeyValueType/Exponent

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Exponent" type="ds:CryptoBinary"/>


element ds:RetrievalMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RetrievalMethodType
properties
content complex
children | ds:Transforms
used by
complexType ds:KeyInfoType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source | <element name="RetrievalMethod" type="ds:RetrievalMethodType"/>


element ds:Transforms

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformsType
properties
content complex
children | ds:Transform
used by
complexTypes ds:ReferenceType ds:RetrievalMethodType
source | <element name="Transforms" type="ds:TransformsType"/>


element ds:Transform

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformType
properties
content | complex
mixed | true
children | ds:XPath
used by
complexTypes ds:TransformsType xenc:TransformsType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="Transform" type="ds:TransformType"/>


element ds:TransformType/XPath

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="XPath" type="string"/>


element ds:X509Data

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509DataType
properties
content complex
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
complexType ds:KeyInfoType
source | <element name="X509Data" type="ds:X509DataType"/>


element ds:X509DataType/X509IssuerSerial

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509IssuerSerialType
properties
isRef | 0
content | complex
children | ds:X509IssuerName ds:X509SerialNumber
source | <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>


element ds:X509IssuerSerialType/X509IssuerName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509IssuerName" type="string"/>


element ds:X509IssuerSerialType/X509SerialNumber

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
properties
isRef | 0
content | simple
source | <element name="X509SerialNumber" type="integer"/>


element ds:X509DataType/X509SKI

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509SKI" type="base64Binary"/>


element ds:X509DataType/X509SubjectName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509SubjectName" type="string"/>


element ds:X509DataType/X509Certificate

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509Certificate" type="base64Binary"/>


element ds:X509DataType/X509CRL

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509CRL" type="base64Binary"/>


element ds:PGPData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:PGPDataType
properties
content complex
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
complexType ds:KeyInfoType
source | <element name="PGPData" type="ds:PGPDataType"/>


element ds:PGPDataType/PGPKeyID

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyID" type="base64Binary"/>


element ds:PGPDataType/PGPKeyPacket

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyPacket" type="base64Binary"/>


element ds:SPKIData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SPKIDataType
properties
content complex
children | ds:SPKISexp
used by
complexType ds:KeyInfoType
source | <element name="SPKIData" type="ds:SPKIDataType"/>


element ds:SPKIDataType/SPKISexp

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="SPKISexp" type="base64Binary"/>


element ds:MgmtData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="MgmtData" type="string"/>


element xenc:CipherData

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherDataType
properties
content complex
children | xenc:CipherValue xenc:CipherReference
used by
complexType xenc:EncryptedType
source | <element name="CipherData" type="xenc:CipherDataType"/>


element xenc:CipherDataType/CipherValue

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="CipherValue" type="base64Binary"/>


element xenc:CipherReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherReferenceType
properties
content complex
children | xenc:Transforms
used by
complexType xenc:CipherDataType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="CipherReference" type="xenc:CipherReferenceType"/>


element xenc:CipherReferenceType/Transforms

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:TransformsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ds:Transform
source | <element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>


element xenc:EncryptionProperties

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertiesType
properties
content complex
children | xenc:EncryptionProperty
used by
complexType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="EncryptionProperties" type="xenc:EncryptionPropertiesType"/>


element xenc:EncryptionProperty

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertyType
properties
content | complex
mixed | true
used by
complexType xenc:EncryptionPropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source | <element name="EncryptionProperty" type="xenc:EncryptionPropertyType"/>


element ds:Signature

Annotation The optional ds:Signature (as defined by W3C) signs the payload element by using the private certificate of the sending party represented by the transport@to GLN.
See the "notes about signature" in the introduction chapter for further guidance about the signature.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureType
properties
content complex
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
complexType requestType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Signature" type="ds:SignatureType"/>


element ds:SignedInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignedInfoType
properties
content complex
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignedInfo" type="ds:SignedInfoType"/>


element ds:CanonicalizationMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CanonicalizationMethodType
properties
content | complex
mixed | true
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="CanonicalizationMethod" type="ds:CanonicalizationMethodType"/>


element ds:SignatureMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureMethodType
properties
content | complex
mixed | true
children | ds:HMACOutputLength
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="SignatureMethod" type="ds:SignatureMethodType"/>


element ds:SignatureMethodType/HMACOutputLength

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:HMACOutputLengthType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>


element ds:Reference

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ReferenceType
properties
content complex
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
complexTypes ds:ManifestType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source | <element name="Reference" type="ds:ReferenceType"/>


element ds:DigestMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestMethodType
properties
content | complex
mixed | true
used by
complexType ds:ReferenceType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="DigestMethod" type="ds:DigestMethodType"/>


element ds:DigestValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestValueType
properties
content simple
used by
complexType ds:ReferenceType
source | <element name="DigestValue" type="ds:DigestValueType"/>


element ds:SignatureValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureValueType
properties
content complex
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureValue" type="ds:SignatureValueType"/>


element ds:Object

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ObjectType
properties
content | complex
mixed | true
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="Object" type="ds:ObjectType"/>


Alphabetical list of used XSD definitions

Alphabetical list of used XSD definitions

The following subchapters list all XSD definitions (simpleType, complexType etc.) used in the schema in alphabetical order.

B
billerAddressType
bodyType
C
companyType
creditType
D
debitorAddressType
dependsOnType
documentType
documentsType
ds_CanonicalizationMethodType
ds_CryptoBinary
ds_DSAKeyValueType
ds_DigestMethodType
ds_DigestValueType
ds_HMACOutputLengthType
ds_KeyInfoType
ds_KeyValueType
ds_ManifestType
ds_ObjectType
ds_PGPDataType
ds_RSAKeyValueType
ds_ReferenceType
ds_RetrievalMethodType
ds_SPKIDataType
ds_SignatureMethodType
ds_SignaturePropertiesType
ds_SignaturePropertyType
ds_SignatureType
ds_SignatureValueType
ds_SignedInfoType
ds_TransformType
ds_TransformsType
ds_X509DataType
ds_X509IssuerSerialType
E
eanPartyType
H
homeCareType
I
insuranceAddressType
ivgLawType
K
kvgLawType
M
mvgLawType
N
nifPartyType
nonEmptyStringType
nursinghomeCareType
O
onlineAddressType
orgLawType
P
patientAddressType
payloadType
personType
planningDataType
planningRecordType
planningRecordsType
postalAddressType
postpartumCareType
processingType
prologType
providerAddressType
R
referrerAddressType
requestType
S
serviceRecordType
serviceRecordsType
softwareType
ssnPartyType
stringType1_12
stringType1_15
stringType1_25
stringType1_255
stringType1_3
stringType1_30
stringType1_35
stringType1_350
stringType1_50
stringType1_64
stringType1_70
stringType1_9
T
telecomAddressType
transportType
treatmentType
U
uvgLawType
V
vvgLawType
X
xenc_AgreementMethodType
xenc_CipherDataType
xenc_CipherReferenceType
xenc_EncryptedDataType
xenc_EncryptedKeyType
xenc_EncryptedType
xenc_EncryptionMethodType
xenc_EncryptionPropertiesType
xenc_EncryptionPropertyType
xenc_KeySizeType
xenc_ReferenceType
xenc_TransformsType
Z


complexType billerAddressType

diagram
namespace | http://sumex1.net/ccr
children | ccr:company ccr:person
used by
element bodyType/biller
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
zsr ccr:zsrPartyType
specialty ccr:stringType1_350
uid_number ccr:stringType1_15
attributes annotations
Name | Notes
ean_party | ean_party is the biller's GLN as defined by RefData
zsr | zsr is the biller's ZSR (KSK) as defined by Santésuisse
specialty | specialty is the biller's specialty (branch of medical science a medical person practices)
uid_number uid_number is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789
source <complexType name="billerAddressType">
<choice>
<element name="company" type="ccr:companyType"/>
<element name="person" type="ccr:personType"/>
</choice>
<attribute name="ean_party" type="ccr:eanPartyType" use="required"/>
<attribute name="zsr" type="ccr:zsrPartyType"/>
<attribute name="specialty" type="ccr:stringType1_350"/>
<attribute name="uid_number" type="ccr:stringType1_15"/>
</complexType>


complexType bodyType

diagram
namespace | http://sumex1.net/ccr
children | ccr:prolog ccr:remark ccr:biller ccr:provider ccr:additional_provider ccr:insurance ccr:debitor ccr:referrer ccr:patient ccr:planning_data ccr:documents
used by
element payloadType/body
source <complexType name="bodyType">
<sequence>
<element name="prolog" type="ccr:prologType"/>
<element name="remark" type="ccr:stringType1_350" minOccurs="0"/>
<element name="biller" type="ccr:billerAddressType"/>
<element name="provider" type="ccr:providerAddressType"/>
<element name="additional_provider" type="ccr:providerAddressType" minOccurs="0" maxOccurs="unbounded"/>
<element name="insurance" type="ccr:insuranceAddressType"/>
<element name="debitor" type="ccr:debitorAddressType"/>
<element name="referrer" type="ccr:referrerAddressType" minOccurs="0"/>
<element name="patient" type="ccr:patientAddressType"/>
<element name="planning_data" type="ccr:planningDataType"/>
<element name="documents" type="ccr:documentsType" minOccurs="0"/>
</sequence>
</complexType>


complexType companyType

diagram
namespace | http://sumex1.net/ccr
children | ccr:companyname ccr:department ccr:subaddressing ccr:postal ccr:telecom ccr:online
used by
elements billerAddressType/company providerAddressType/company insuranceAddressType/company debitorAddressType/company referrerAddressType/company
source <complexType name="companyType">
<sequence>
<element name="companyname" type="ccr:stringType1_35"/>
<element name="department" type="ccr:stringType1_35" minOccurs="0"/>
<element name="subaddressing" type="ccr:stringType1_35" minOccurs="0"/>
<element name="postal" type="ccr:postalAddressType"/>
<element name="telecom" type="ccr:telecomAddressType" minOccurs="0"/>
<element name="online" type="ccr:onlineAddressType" minOccurs="0"/>
</sequence>
</complexType>


complexType creditType

diagram
namespace http://sumex1.net/ccr
used by
elements payloadType/credit payloadType/credit_ref
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | ccr:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the credit's infoset generation
This is one of 3 identifiers that form the credit object reference. request_timestamp will be generated once for a certain credit object reference and thereafter always referenced!
request_date request_date is the main software's date of the credit request ("Kostenvoranschlagdatum")
This is one of 3 identifiers that form the credit object reference. request_date must be identical for the same credit object reference!
request_id request_id is the main software's ID of the credit request ("Kostenvoranschlagnummer")
This is one of 3 identifiers that form the credit object reference. request_id must be identical for the same credit object reference!
source <complexType name="creditType">
<attribute name="request_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="1924902000"/>
</restriction>
</simpleType>
</attribute>
<attribute name="request_date" type="dateTime" use="required"/>
<attribute name="request_id" type="ccr:stringType1_35" use="required"/>
</complexType>


complexType debitorAddressType

diagram
namespace | http://sumex1.net/ccr
children | ccr:company ccr:person
used by
element bodyType/debitor
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
attributes annotations
Name Notes
ean_party ean_party is the debitor's GLN number as defined by RefData
Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
source <complexType name="debitorAddressType">
<choice>
<element name="company" type="ccr:companyType"/>
<element name="person" type="ccr:personType"/>
</choice>
<attribute name="ean_party" type="ccr:eanPartyType" use="required"/>
</complexType>


complexType dependsOnType

diagram
namespace http://sumex1.net/ccr
used by
element softwareType/depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | ccr:stringType1_50 | required
copyright ccr:stringType1_50
description ccr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source <complexType name="dependsOnType">
<attribute name="name" type="ccr:stringType1_50" use="required"/>
<attribute name="copyright" type="ccr:stringType1_50"/>
<attribute name="description" type="ccr:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType documentsType

diagram
namespace | http://sumex1.net/ccr
children | ccr:document
used by
element bodyType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source <complexType name="documentsType">
<sequence>
<element name="document" type="ccr:documentType" maxOccurs="unbounded"/>
</sequence>
<attribute name="number" type="unsignedLong" use="required"/>
</complexType>


complexType documentType

diagram
namespace | http://sumex1.net/ccr
children | ccr:base64
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
title | ccr:stringType1_35 | required
filename | ccr:stringType1_255 | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
title title is the document's title on the primary system and thus describes the document in terms of its semantic content.
A list of possible suggestions -heuristic and incomplete in its nature- can be found at the Sumex1.
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME sniffing.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reduce the allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
source <complexType name="documentType">
<choice>
<element name="base64" type="base64Binary"/>
</choice>
<attribute name="title" type="ccr:stringType1_35" use="required"/>
<attribute name="filename" type="ccr:stringType1_255" use="required"/>
<attribute name="mimeType" use="required">
<simpleType>
<restriction base="string">
<pattern value="(application/pdf|image/jpeg|image/png)"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType ds:CanonicalizationMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:CanonicalizationMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="CanonicalizationMethodType" mixed="true">
<sequence>
<any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DigestMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:DigestMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="DigestMethodType" mixed="true">
<sequence>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
element ds:DSAKeyValue
source <complexType name="DSAKeyValueType">
<sequence>
<sequence minOccurs="0">
<element name="P" type="ds:CryptoBinary"/>
<element name="Q" type="ds:CryptoBinary"/>
</sequence>
<element name="G" type="ds:CryptoBinary" minOccurs="0"/>
<element name="Y" type="ds:CryptoBinary"/>
<element name="J" type="ds:CryptoBinary" minOccurs="0"/>
<sequence minOccurs="0">
<element name="Seed" type="ds:CryptoBinary"/>
<element name="PgenCounter" type="ds:CryptoBinary"/>
</sequence>
</sequence>
</complexType>


complexType ds:KeyInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
elements ds:KeyInfo xenc:AgreementMethodType/OriginatorKeyInfo xenc:AgreementMethodType/RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="KeyInfoType" mixed="true">
<choice maxOccurs="unbounded">
<element ref="ds:KeyName"/>
<element ref="ds:KeyValue"/>
<element ref="ds:RetrievalMethod"/>
<element ref="ds:X509Data"/>
<element ref="ds:PGPData"/>
<element ref="ds:SPKIData"/>
<element ref="ds:MgmtData"/>
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
</choice>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:KeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
element ds:KeyValue
source <complexType name="KeyValueType" mixed="true">
<choice>
<element ref="ds:DSAKeyValue"/>
<element ref="ds:RSAKeyValue"/>
<any namespace="##other" processContents="lax"/>
</choice>
</complexType>


complexType ds:ManifestType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Reference
used by
element ds:Manifest
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="ManifestType">
<sequence>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:ObjectType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:Object
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="ObjectType" mixed="true">
<sequence minOccurs="0" maxOccurs="unbounded">
<any namespace="##any" processContents="lax"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
<!-- add a grep facet -->
</complexType>


complexType ds:PGPDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
element ds:PGPData
source <complexType name="PGPDataType">
<choice>
<sequence>
<element name="PGPKeyID" type="base64Binary"/>
<element name="PGPKeyPacket" type="base64Binary" minOccurs="0"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<sequence>
<element name="PGPKeyPacket" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</choice>
</complexType>


complexType ds:ReferenceType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
element ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source <complexType name="ReferenceType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
<element ref="ds:DigestMethod"/>
<element ref="ds:DigestValue"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="URI" type="anyURI" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RetrievalMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms
used by
element ds:RetrievalMethod
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source <complexType name="RetrievalMethodType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
</sequence>
<attribute name="URI" type="anyURI"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Modulus ds:Exponent
used by
element ds:RSAKeyValue
source <complexType name="RSAKeyValueType">
<sequence>
<element name="Modulus" type="ds:CryptoBinary"/>
<element name="Exponent" type="ds:CryptoBinary"/>
</sequence>
</complexType>


complexType ds:SignatureMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:HMACOutputLength
used by
element ds:SignatureMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="SignatureMethodType" mixed="true">
<sequence>
<element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) external namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:SignaturePropertiesType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignatureProperty
used by
element ds:SignatureProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignaturePropertiesType">
<sequence>
<element ref="ds:SignatureProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


element ds:SignatureProperty

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertyType
properties
content | complex
mixed | true
used by
complexType ds:SignaturePropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source | <element name="SignatureProperty" type="ds:SignaturePropertyType"/>


complexType ds:SignaturePropertyType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source <complexType name="SignaturePropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (1,unbounded) namespaces -->
</choice>
<attribute name="Target" type="anyURI" use="required"/>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
element ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureType">
<sequence>
<element ref="ds:SignedInfo"/>
<element ref="ds:SignatureValue"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="ds:Object" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | extension of base64Binary
properties
base base64Binary
used by
element ds:SignatureValue
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureValueType">
<simpleContent>
<extension base="base64Binary">
<attribute name="Id" type="ID" use="optional"/>
</extension>
</simpleContent>
</complexType>


complexType ds:SignedInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
element ds:SignedInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignedInfoType">
<sequence>
<element ref="ds:CanonicalizationMethod"/>
<element ref="ds:SignatureMethod"/>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SPKIDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SPKISexp
used by
element ds:SPKIData
source <complexType name="SPKIDataType">
<sequence maxOccurs="unbounded">
<element name="SPKISexp" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0"/>
</sequence>
</complexType>


complexType ds:TransformsType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transform
used by
element ds:Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType ds:TransformType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:XPath
used by
element ds:Transform
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="TransformType" mixed="true">
<choice minOccurs="0" maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
<element name="XPath" type="string"/>
</choice>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:X509DataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
element ds:X509Data
source <complexType name="X509DataType">
<sequence maxOccurs="unbounded">
<choice>
<element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
<element name="X509SKI" type="base64Binary"/>
<element name="X509SubjectName" type="string"/>
<element name="X509Certificate" type="base64Binary"/>
<element name="X509CRL" type="base64Binary"/>
<any namespace="##other" processContents="lax"/>
</choice>
</sequence>
</complexType>


complexType ds:X509IssuerSerialType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerName ds:X509SerialNumber
used by
element ds:X509DataType/X509IssuerSerial
source <complexType name="X509IssuerSerialType">
<sequence>
<element name="X509IssuerName" type="string"/>
<element name="X509SerialNumber" type="integer"/>
</sequence>
</complexType>


complexType homeCareType

diagram
namespace http://sumex1.net/ccr
used by
element planningDataType/home_care
attributes parameters
Name | Type | Use | Default | Fixed
planning_catalog | ccr:stringType1_15 | required
stay_daycare_center | boolean | false
domestic_aid_days_per_week | nonNegativeInteger | 0
domestic_aid_hours_per_day | nonNegativeInteger | 0
migel_selfapplication | boolean | false
attributes annotations
Name | Notes
planning_catalog planning_catalog defines the main planning catalog edition.
Note, that the planning_catalog is an unstandardized string consisting of a slash-separated planning catalog name and edition e.g. "RAI-NC/2018" or "BESA/2018".
domestic_aid_days_per_week | a positive value of the domestic_aid_days_per_week indicates that the patient currently has a household aid the defined days per week. Conversely, a value of 0 means no domestic aid.
domestic_aid_hours_per_day | a positive value of the domestic_aid_hours_per_day indicates that the patient currently has a household aid the defined hours per day. Conversely, a value of 0 means no domestic aid.
stay_daycare_center | stay_daycare_center indicates if a patient is staying in a day-care center during daytime.
migel_selfapplication | migel_selfapplication indicates whether the patient receives MiGel care products for self-application from the home care organisation
source <complexType name="homeCareType">
<attribute name="planning_catalog" type="ccr:stringType1_15" use="required"/>
<attribute name="stay_daycare_center" type="boolean" default="false"/>
<attribute name="domestic_aid_days_per_week" type="nonNegativeInteger" default="0"/>
<attribute name="domestic_aid_hours_per_day" type="nonNegativeInteger" default="0"/>
<attribute name="migel_selfapplication" type="boolean" default="false"/>
</complexType>


complexType insuranceAddressType

diagram
namespace | http://sumex1.net/ccr
children | ccr:company ccr:person
used by
element bodyType/insurance
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
attributes annotations
Name | Notes
ean_party | ean_party is the insurance's GLN as defined by RefData
source <complexType name="insuranceAddressType">
<choice>
<element name="company" type="ccr:companyType"/>
<element name="person" type="ccr:personType"/>
</choice>
<attribute name="ean_party" type="ccr:eanPartyType" use="required"/>
</complexType>


complexType ivgLawType

diagram
namespace http://sumex1.net/ccr
used by
element planningDataType/ivg
attributes parameters
Name | Type | Use | Default | Fixed
case_id | derived by: string | required
case_date | dateTime
ssn | ccr:ssnPartyType | required
nif ccr:nifPartyType
attributes annotations
Name | Notes
case_id | case_id is the treatment/case identification given by the insurance (order number)
case_date | case_date is the treatment/case date given by the insurance (order date)
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
nif | nif is the IV specific identification number for the provider.
source <complexType name="ivgLawType">
<attribute name="case_id" use="required">
<simpleType>
<restriction base="string">
<pattern value="([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6})"/>
</restriction>
</simpleType>
</attribute>
<attribute name="case_date" type="dateTime"/>
<attribute name="ssn" type="ccr:ssnPartyType" use="required"/>
<attribute name="nif" type="ccr:nifPartyType"/>
</complexType>


complexType kvgLawType

diagram
namespace http://sumex1.net/ccr
used by
element planningDataType/kvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id ccr:stringType1_35
case_id ccr:stringType1_35
case_date | dateTime
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
source <complexType name="kvgLawType">
<attribute name="insured_id" type="ccr:stringType1_35"/>
<attribute name="case_id" type="ccr:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
</complexType>


complexType mvgLawType

diagram
namespace http://sumex1.net/ccr
used by
element planningDataType/mvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id ccr:stringType1_35
case_id ccr:stringType1_35
case_date | dateTime
ssn | ccr:ssnPartyType | required
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
source <complexType name="mvgLawType">
<attribute name="insured_id" type="ccr:stringType1_35"/>
<attribute name="case_id" type="ccr:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="ssn" type="ccr:ssnPartyType" use="required"/>
</complexType>


complexType nursinghomeCareType

diagram
namespace http://sumex1.net/ccr
used by
element planningDataType/nursinghome_care
attributes parameters
Name | Type | Use | Default | Fixed
planning_catalog | ccr:stringType1_15 | required
care_demand_level | ccr:stringType1_15 | required
assessment_date | dateTime
accommodation_type | positiveInteger | required
attributes annotations
Name Notes
planning_catalog planning_catalog defines the main planning catalog edition.
Note, that the planning_catalog is an unstandardized string consisting of a slash-separated planning catalog name and edition e.g. "RAI-NC/2018" or "BESA/2018".
care_demand_level care_demand_level defines the assed care demand level for the patient.
Note, that the care_demand_level is an unstandardized string consisting of a planning catalog name and care level number e.g. "BESA5" or "PLAISIR3".
assessment_date assessment_date defines the date at which the assessment for the care demand level was performed
Note, that the assessment date is equal or before the treatment start date.
accommodation_type accommodation_typer defines the type of accommodation encodes by an integer number. Currently, there are the following values with a semantic meaning defined, namely
  • accommodation_type=1 aka "long-term stay"
  • accommodation_type=2 aka "short-term stay"
  • accommodation_type=3 aka "person not accommodated"
  • accommodation_type=4 aka "day and night structure"
  • accommodation_type=5 aka "acute and transitional care"
source <complexType name="nursinghomeCareType">
<attribute name="planning_catalog" type="ccr:stringType1_15" use="required"/>
<attribute name="care_demand_level" type="ccr:stringType1_15" use="required"/>
<attribute name="assessment_date" type="dateTime"/>
<attribute name="accommodation_type" type="positiveInteger" use="required"/>
</complexType>


complexType onlineAddressType

diagram
namespace | http://sumex1.net/ccr
children | ccr:email ccr:url
used by
elements personType/online companyType/online
source <complexType name="onlineAddressType">
<sequence>
<element name="email" maxOccurs="3">
<simpleType>
<restriction base="ccr:stringType1_70">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>
<element name="url" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>
</element>
</sequence>
</complexType>


complexType orgLawType

diagram
namespace http://sumex1.net/ccr
used by
element planningDataType/org
attributes parameters
Name | Type | Use | Default | Fixed
insured_id ccr:stringType1_35
case_id ccr:stringType1_35
case_date | dateTime
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance,
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
source <complexType name="orgLawType">
<attribute name="insured_id" type="ccr:stringType1_35"/>
<attribute name="case_id" type="ccr:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
</complexType>


complexType patientAddressType

diagram
namespace | http://sumex1.net/ccr
children | ccr:person ccr:card
used by
element bodyType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn ccr:ssnPartyType
disability_allowance | derived by: NMTOKEN | none
incontinence_degree | derived by: NMTOKEN | none
attributes annotations
Name | Notes
gender | gender defines the gender encoded by a terminal set of tokens
birthdate | birthdate defines the birthdate of the patient
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
disability_allowance | disability_allowance defines the degree of disability allowance gender encoded by a terminal set of tokens
incontinence_degree | incontinence_degree defines the degree of incontinence encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
disability_allowance | NMTOKEN | none | the degree of disability allowance is none
disability_allowance | NMTOKEN | low | the degree of disability allowance is low
disability_allowance | NMTOKEN | medium | the degree of disability allowance is medium
disability_allowance | NMTOKEN | high | the degree of disability allowance is high
gender | NMTOKEN | male | the gender is male
gender | NMTOKEN | female | the gender is female
incontinence_degree | NMTOKEN | none | the degree of incontinence is none
incontinence_degree | NMTOKEN | low | the degree of incontinence is low
incontinence_degree | NMTOKEN | medium | the degree of incontinence is medium
incontinence_degree | NMTOKEN | high | the degree of incontinence is high
source <complexType name="patientAddressType">
<sequence>
<element name="person" type="ccr:personType"/>
<element name="card" minOccurs="0">
<complexType>
<attribute name="card_id" type="ccr:stringType1_35" use="required"/>
<attribute name="expiry_date" type="dateTime"/>
<attribute name="validation_date" type="dateTime"/>
<attribute name="validation_id" type="ccr:stringType1_35"/>
<attribute name="validation_server" type="ccr:stringType1_35"/>
</complexType>
</element>
</sequence>
<attribute name="gender" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
</restriction>
</simpleType>
</attribute>
<attribute name="birthdate" type="dateTime" use="required"/>
<attribute name="ssn" type="ccr:ssnPartyType"/>
<attribute name="disability_allowance" default="none">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="none"/>
<enumeration value="low"/>
<enumeration value="medium"/>
<enumeration value="high"/>
</restriction>
</simpleType>
</attribute>
<attribute name="incontinence_degree" default="none">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="none"/>
<enumeration value="low"/>
<enumeration value="medium"/>
<enumeration value="high"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType payloadType

diagram
namespace | http://sumex1.net/ccr
children | ccr:credit_ref ccr:credit ccr:body xenc:EncryptedData
used by
element requestType/payload
attributes parameters
Name | Type | Use | Default | Fixed
storno | boolean | false
copy | boolean | false
attributes annotations
Name | Notes
storno | storno augments the CCR reference object by a storno command that is the CCR reference object is an identical clone (except for the storno attribute) of a prior sent request.
copy | copy augments the CCR reference object by a copy command that is the CCR reference object is an identical clone (except for the copy attribute) of a prior sent request.
source <complexType name="payloadType">
<sequence>
<element name="credit_ref" type="ccr:creditType" minOccurs="0"/>
<element name="credit" type="ccr:creditType"/>
<choice>
<element name="body" type="ccr:bodyType"/>
<element ref="xenc:EncryptedData"/>
</choice>
</sequence>
<attribute name="storno" type="boolean" default="false"/>
<attribute name="copy" type="boolean" default="false"/>
</complexType>


complexType personType

diagram
namespace | http://sumex1.net/ccr
children | ccr:familyname ccr:givenname ccr:subaddressing ccr:postal ccr:telecom ccr:online
used by
elements billerAddressType/person providerAddressType/person insuranceAddressType/person debitorAddressType/person referrerAddressType/person patientAddressType/person
attributes parameters
Name Type Use Default Fixed
salutation ccr:stringType1_35
title ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="personType">
<sequence>
<element name="familyname" type="ccr:stringType1_35"/>
<element name="givenname" type="ccr:stringType1_35"/>
<element name="subaddressing" type="ccr:stringType1_35" minOccurs="0"/>
<element name="postal" type="ccr:postalAddressType"/>
<element name="telecom" type="ccr:telecomAddressType" minOccurs="0"/>
<element name="online" type="ccr:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="ccr:stringType1_35"/>
<attribute name="title" type="ccr:stringType1_35"/>
</complexType>


complexType planningDataType

diagram
namespace | http://sumex1.net/ccr
children | ccr:kvg ccr:vvg ccr:uvg ccr:ivg ccr:mvg ccr:org ccr:treatment ccr:postpartum_care ccr:home_care ccr:nursinghome_care ccr:planning_records ccr:service_records
used by
element bodyType/planning_data
attributes parameters
Name | Type | Use | Default | Fixed
ordinance_type | derived by: NMTOKEN | first
provider_number | positiveInteger | 4
attributes annotations
Name | Notes
ordinance_type | ordinance_type defines the type of ordinance request encoded by a terminal set of tokens
provider_number provider_number is a qualification number of the care provider.
Currently the are 2 distinct values defined and recognized, namely
  • provider_number=4 aka home care organisation
  • provider_number=5 aka nursing home organisation
attributes enumerations
Name | Extension | Base | Value | Annotations
ordinance_type | NMTOKEN | first | the ordinance is of type first - an initial ordinance request
ordinance_type | NMTOKEN | followup | the ordinance is of type followup - a followup ordinance request following the first ordinance
ordinance_type | NMTOKEN | modification | the ordinance is of type modification - an ordinance request whose data space is modified regarding a previously sent but rejected ordinance
ordinance_type | NMTOKEN | re-consideration | the ordinance is of type re-consideration - an ordinance request whose data space is unmodified but possibly extended by further documents and is sent for a re-consideration at the recipient's site.
ordinance_type | NMTOKEN | transient | the ordinance is of type transient - a transient ordinance request defining a transient care situation for a limited and foreseeable time.
source <complexType name="planningDataType">
<sequence>
<choice>
<element name="kvg" type="ccr:kvgLawType"/>
<element name="vvg" type="ccr:vvgLawType"/>
<element name="uvg" type="ccr:uvgLawType"/>
<element name="ivg" type="ccr:ivgLawType"/>
<element name="mvg" type="ccr:mvgLawType"/>
<element name="org" type="ccr:orgLawType"/>
</choice>
<element name="treatment" type="ccr:treatmentType"/>
<element name="postpartum_care" type="ccr:postpartumCareType" minOccurs="0"/>
<element name="home_care" type="ccr:homeCareType" minOccurs="0"/>
<element name="nursinghome_care" type="ccr:nursinghomeCareType" minOccurs="0"/>
<element name="planning_records" type="ccr:planningRecordsType" minOccurs="0"/>
<element name="service_records" type="ccr:serviceRecordsType" minOccurs="0"/>
</sequence>
<attribute name="ordinance_type" default="first">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="first"/>
<enumeration value="followup"/>
<enumeration value="modification"/>
<enumeration value="re-consideration"/>
<enumeration value="transient"/>
</restriction>
</simpleType>
</attribute>
<attribute name="provider_number" type="positiveInteger" default="4"/>
</complexType>


complexType planningRecordsType

diagram
namespace | http://sumex1.net/ccr
children | ccr:planning_record
used by
element planningDataType/planning_records
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines the total number of planning records
source <complexType name="planningRecordsType">
<sequence>
<element name="planning_record" type="ccr:planningRecordType" maxOccurs="unbounded"/>
</sequence>
<attribute name="number" type="unsignedLong" use="required"/>
</complexType>


complexType planningRecordType

diagram
namespace http://sumex1.net/ccr
used by
element planningRecordsType/planning_record
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required
service_id | derived by: int
catalog_type | ccr:stringType1_15 | required
catalog_code | ccr:stringType1_30 | required
catalog_name | ccr:stringType1_350 | required
quantity | double | required
multiplier_symbol | derived by: string | e
multiplier | double | 1
base_unit | double | required
is_training | boolean | false
corr_unit | double | 0
total_unit | double | required
remark ccr:stringType1_350
attributes annotations
Name | Notes
record_id | record_id is a record sequence number (starting with 1 and incremented by 1 for each further record) uniquely identifying the record
service_id the optional service_id is a service record pointer that maps the planning record to the corresponding service record that is the planning data is connect the the incurred cost record.
Note that an absent service_id means that no billing portion can be linked to the planning record.
catalog_type | catalog_type is the official planning catalog designator e.g. "RAI-NC", "BESA 5", "KLV7" and the like
catalog_code | catalog_code is the code of the used planning record as defined in the planning catalog
catalog_name | catalog_name is the official name of the planning record as defined in the planning catalog
quantity quantity is the used quantity of the current planning record
Note, that the quantity is defined as double, spanning negative, zero and positive fractional values!
  • negative quantities are used to effectively "subtract" planning records from the grand total
  • a zero quantity is used for "non-billable" and "pro memoria" planning records
  • positive quantities are used for "normal" planning records
quantity must not be rounded but given in full precision.
multiplier_symbol | multiplier_symbol corresponds to a temporal multiplication function that distributes a singular object over the whole treatment interval. The functional behaviour is supplied by a set of (language-dependent) symbols like "t3", "w" etc.
multiplier multiplier is the numerical representation of the multiplier_symbol and defines the multiplication factor that a singular object is distributed over the whole treatment interval.
Please note, that the magnitude of the multiplier might be fractional since an instruction like "t3" might not be transformed integer dependent on the given treatment interval.
base_unit | base_unit defines the base unit of a singular object as defined in the planning catalog
is_training | is_training is a Boolean value that indicates whether the planning record is performed in training mode.
corr_unit corr_value defines an optional correctional unit that is added to the total unit.

Please note, that the sign is significant, i.e. a downscale correction corresponds to a negative value. Furthermore, "corr_value" is an absolute value and is not modulated by "quantity" and "multiplier" (cf. defined equation under "total_unit").

The necessity of a correction depends on the used catalog and is justified in the non-orthogonality of the catalog records.
total_unit total_unit defines the calculated units over the treatment interval as given by the equation:
«( quantity * multiplier * base_unit ) + corr_unit = total_unit »

The equation is calculated in full precision and the result rounded to 2 significant decimal places.
remark | remark is an optional remark for the applied planning record
source <complexType name="planningRecordType">
<attribute name="record_id" use="required">
<simpleType>
<restriction base="int">
<minInclusive value="1"/>
<maxInclusive value="999999999"/>
</restriction>
</simpleType>
</attribute>
<attribute name="service_id">
<simpleType>
<restriction base="int">
<minInclusive value="1"/>
<maxInclusive value="999999999"/>
</restriction>
</simpleType>
</attribute>
<attribute name="catalog_type" type="ccr:stringType1_15" use="required"/>
<attribute name="catalog_code" type="ccr:stringType1_30" use="required"/>
<attribute name="catalog_name" type="ccr:stringType1_350" use="required"/>
<attribute name="quantity" type="double" use="required"/>
<attribute name="multiplier_symbol" default="e">
<simpleType>
<restriction base="string">
<pattern value="[A-Za-z0-9]{1,3}"/>
</restriction>
</simpleType>
</attribute>
<attribute name="multiplier" type="double" default="1"/>
<attribute name="base_unit" type="double" use="required"/>
<attribute name="is_training" type="boolean" default="false"/>
<attribute name="corr_unit" type="double" default="0"/>
<attribute name="total_unit" type="double" use="required"/>
<attribute name="remark" type="ccr:stringType1_350"/>
</complexType>


complexType postalAddressType

diagram
namespace | http://sumex1.net/ccr
children | ccr:pobox ccr:street ccr:zip ccr:city
used by
elements personType/postal companyType/postal
source <complexType name="postalAddressType">
<sequence>
<sequence>
<element name="pobox" type="ccr:stringType1_35" minOccurs="0"/>
<element name="street" type="ccr:stringType1_35" minOccurs="0"/>
</sequence>
<element name="zip" type="ccr:zipType"/>
<element name="city" type="ccr:stringType1_35"/>
</sequence>
</complexType>


complexType postpartumCareType

diagram
namespace http://sumex1.net/ccr
used by
element planningDataType/postpartum_care
attributes parameters
Name | Type | Use | Default | Fixed
planning_catalog | ccr:stringType1_15 | required
date_of_birth | dateTime | required
domestic_aid_days_per_week | nonNegativeInteger | 0
domestic_aid_hours_per_day | nonNegativeInteger | 0
migel_selfapplication | boolean | false
attributes annotations
Name | Notes
planning_catalog planning_catalog defines the main planning catalog edition.
Note, that the planning_catalog is an unstandardized string consisting of a slash-separated planning catalog name and edition e.g. "RAI-NC/2018" or "BESA/2018".
date_of_birth date_of_birth defines the date and time of a recently born neonate of the patient.
Please note that the birth of the child qualifies the mother for possible home care. Therefore, the date of birth by definition must be close to the date of planned treatment.
domestic_aid_days_per_week | a positive value of the domestic_aid_days_per_week indicates that the patient currently has a household aid the defined days per week. Conversely, a value of 0 means no domestic aid.
domestic_aid_hours_per_day | a positive value of the domestic_aid_hours_per_day indicates that the patient currently has a household aid the defined hours per day. Conversely, a value of 0 means no domestic aid.
migel_selfapplication | migel_selfapplication indicates whether the patient receives MiGel care products for self-application from the home care organisation
source <complexType name="postpartumCareType">
<attribute name="planning_catalog" type="ccr:stringType1_15" use="required"/>
<attribute name="date_of_birth" type="dateTime" use="required"/>
<attribute name="domestic_aid_days_per_week" type="nonNegativeInteger" default="0"/>
<attribute name="domestic_aid_hours_per_day" type="nonNegativeInteger" default="0"/>
<attribute name="migel_selfapplication" type="boolean" default="false"/>
</complexType>


complexType processingType

diagram
namespace | http://sumex1.net/ccr
children | ccr:transport
used by
element requestType/processing
source <complexType name="processingType">
<sequence>
<element name="transport" type="ccr:transportType"/>
</sequence>
</complexType>


complexType prologType

diagram
namespace | http://sumex1.net/ccr
children | ccr:package ccr:generator
used by
element bodyType/prolog
source <complexType name="prologType">
<sequence>
<element name="package" type="ccr:softwareType" minOccurs="0"/>
<element name="generator" type="ccr:softwareType"/>
</sequence>
</complexType>


complexType providerAddressType

diagram
namespace | http://sumex1.net/ccr
children | ccr:company ccr:person
used by
elements bodyType/additional_provider bodyType/provider
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
zsr ccr:zsrPartyType
specialty ccr:stringType1_350
attributes annotations
Name | Notes
ean_party | ean_party is the provider's GLN as defined by RefData
zsr | zsr is the provider's ZSR (KSK) as defined by Santésuisse
specialty | specialty is the provider's specialty (branch of medical science a doctor practices)
source <complexType name="providerAddressType">
<choice>
<element name="company" type="ccr:companyType"/>
<element name="person" type="ccr:personType"/>
</choice>
<attribute name="ean_party" type="ccr:eanPartyType" use="required"/>
<attribute name="zsr" type="ccr:zsrPartyType"/>
<attribute name="specialty" type="ccr:stringType1_350"/>
</complexType>


complexType referrerAddressType

diagram
namespace | http://sumex1.net/ccr
children | ccr:company ccr:person
used by
element bodyType/referrer
attributes parameters
Name Type Use Default Fixed
ean_party ccr:eanPartyType
zsr ccr:zsrPartyType
specialty ccr:stringType1_350
attributes annotations
Name | Notes
ean_party | ean_party is the referrer's GLN as defined by RefData
zsr | zsr is the referrer's ZSR as defined by Santésuisse
specialty | specialty is the referrer's medical specialty (branch of medical science a doctor practices)
source <complexType name="referrerAddressType">
<choice>
<element name="company" type="ccr:companyType"/>
<element name="person" type="ccr:personType"/>
</choice>
<attribute name="ean_party" type="ccr:eanPartyType"/>
<attribute name="zsr" type="ccr:zsrPartyType"/>
<attribute name="specialty" type="ccr:stringType1_350"/>
</complexType>


complexType requestType

diagram
namespace | http://sumex1.net/ccr
children | ccr:processing ccr:payload ds:Signature
used by
element request
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
validation_status | long
attributes annotations
Name | Notes
language | language defines the used data language (name of the services etc.) encoded by a terminal set of ISO language specifiers.
modus | modus defines the operating modus encoded by a terminal set of tokens
validation_status validation_status defines the validity status of XML infoset after the infoset is generated and validated by a DOM. 0 or absence of the attribute means OK.
It is possible to knowingly encode an XML infoset that is not well formed or invalid regarding its content. validation_status then signals an error condition to the recipient.
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus | NMTOKEN | test | the modus test is for software developers to test the processing.
source <complexType name="requestType">
<sequence>
<element name="processing" type="ccr:processingType"/>
<element name="payload" type="ccr:payloadType"/>
<element ref="ds:Signature" minOccurs="0"/>
</sequence>
<attribute name="language" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="de"/>
<enumeration value="fr"/>
<enumeration value="it"/>
</restriction>
</simpleType>
</attribute>
<attribute name="modus" default="production">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="production"/>
<enumeration value="test"/>
</restriction>
</simpleType>
</attribute>
<attribute name="validation_status" type="long"/>
</complexType>


complexType serviceRecordsType

diagram
namespace | http://sumex1.net/ccr
children | ccr:service_record
used by
element planningDataType/service_records
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines the total number of service records
source <complexType name="serviceRecordsType">
<sequence>
<element name="service_record" type="ccr:serviceRecordType" maxOccurs="unbounded"/>
</sequence>
<attribute name="number" type="unsignedLong" use="required"/>
</complexType>


complexType serviceRecordType

diagram
namespace http://sumex1.net/ccr
used by
element serviceRecordsType/service_record
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required
tariff_type | derived by: string | required
tariff_code | ccr:stringType1_30 | required
tariff_name | ccr:stringType1_350 | required
quantity | double | required
unit | double | required
unit_factor | derived by: double | 1.0
external_factor | derived by: double | 1.0
amount | double | required
remark ccr:stringType1_350
attributes annotations
Name | Notes
record_id | record_id is a record sequence number (starting with 1 and incremented by 1 for each further record) uniquely identifying the record
tariff_type | tariff_type is the official 3-character designator of the used tariff as given by Sumex1
tariff_code | tariff_code is the code of the service record as given by the used tariff catalog
tariff_name | tariff_name is the official service name as given by the used tariff catalog
quantity quantity is the used quantity of the current service
Note, that the quantity is defined as double, spanning zero and positive fractional values!
  • a zero quantity is used for "non-billable" and "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)
quantity must not be rounded but given in full precision.
unit unit is the tax point (TP) of the applied service
unit is defined as double and must not be rounded but given in full precision.
unit_factor unit_factor is the tax point value (TPV) of the applied service
unit_factor is defined as double and must not be rounded but given in full precision.
external_factor external_factor is a external scale factor for the applied service
external_factor is used as a measure for giving discounts and can even be zero to supply a charge free service.
amount amount is the charged amount of the applied service
Note, that amount must fulfill the equation:
« quantity * TP * TPV * external_factor = amount»

The equations is calculated in full precision and the result rounded to 2 significant decimal places.
remark | remark is an optional remark for the applied service record
source <complexType name="serviceRecordType">
<attribute name="record_id" use="required">
<simpleType>
<restriction base="int">
<minInclusive value="1"/>
<maxInclusive value="999999999"/>
</restriction>
</simpleType>
</attribute>
<attribute name="tariff_type" use="required">
<simpleType>
<restriction base="string">
<pattern value="[0-9A-Z]{3}"/>
</restriction>
</simpleType>
</attribute>
<attribute name="tariff_code" type="ccr:stringType1_30" use="required"/>
<attribute name="tariff_name" type="ccr:stringType1_350" use="required"/>
<attribute name="quantity" type="double" use="required"/>
<attribute name="unit" type="double" use="required"/>
<attribute name="unit_factor" default="1.0">
<simpleType>
<restriction base="double">
<minExclusive value="0.0"/>
</restriction>
</simpleType>
</attribute>
<attribute name="external_factor" default="1.0">
<simpleType>
<restriction base="double">
<minInclusive value="0.0"/>
</restriction>
</simpleType>
</attribute>
<attribute name="amount" type="double" use="required"/>
<attribute name="remark" type="ccr:stringType1_350"/>
</complexType>


complexType softwareType

diagram
namespace | http://sumex1.net/ccr
children | ccr:depends_on
used by
elements prologType/generator prologType/package
attributes parameters
Name | Type | Use | Default | Fixed
name | ccr:stringType1_50 | required
copyright ccr:stringType1_50
description ccr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source <complexType name="softwareType">
<sequence>
<element name="depends_on" type="ccr:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="name" type="ccr:stringType1_50" use="required"/>
<attribute name="copyright" type="ccr:stringType1_50"/>
<attribute name="description" type="ccr:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType telecomAddressType

diagram
namespace | http://sumex1.net/ccr
children | ccr:phone ccr:fax
used by
elements personType/telecom companyType/telecom
source <complexType name="telecomAddressType">
<sequence>
<element name="phone" type="ccr:stringType1_25" maxOccurs="3"/>
<element name="fax" type="ccr:stringType1_25" minOccurs="0" maxOccurs="3"/>
</sequence>
</complexType>


complexType transportType

diagram
namespace | http://sumex1.net/ccr
children | ccr:via
used by
element processingType/transport
attributes parameters
Name | Type | Use | Default | Fixed
from | ccr:eanPartyType | required
to | ccr:eanPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the infoset to the first intermediate
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the infoset from the last intermediate.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source <complexType name="transportType">
<sequence>
<element name="via" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="ccr:eanPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>
</sequence>
<attribute name="from" type="ccr:eanPartyType" use="required"/>
<attribute name="to" type="ccr:eanPartyType" use="required"/>
</complexType>


complexType treatmentType

diagram
namespace http://sumex1.net/ccr
used by
element planningDataType/treatment
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required
date_end | dateTime | required
treatment_days | duration | required
treatment_canton | derived by: NMTOKEN | required
treatment_type | derived by: NMTOKEN | ambulatory
treatment_reason | derived by: NMTOKEN | required
tiers_mode | derived by: NMTOKEN | TP
attributes annotations
Name | Notes
date_begin | date_begin is the start of the planned and planning defined treatment period.
date_end | date_end is the end of the planned and planning defined treatment period.
treatment_days | treatment_days is the number of planned treatment days within the given treatment period.
treatment_canton treatment_canton is Swiss canton or a country close to the border in which the treatment is taking place encoded by a terminal set of tokens.
Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations. Liechtenstein is coded by "LI" as in the prior standards.
treatment_type | treatment_type is the principle type of treatment encoded by a terminal set of tokens.
treatment_reason | treatment_reason is the primary reason why the treatment is taking place encoded by a terminal set of tokens
tiers_mode | tiers_mode is the principle mode of tiers encoded by a terminal set of tokens.
attributes enumerations
Name | Extension | Base | Value | Annotations
tiers_mode | NMTOKEN | TP | the tiers mode is TP aka Tiers Payant (default)
tiers_mode | NMTOKEN | TG | the tiers mode is TG aka Tiers Garant
treatment_canton | NMTOKEN | AG | the canton is AG - Aargau
treatment_canton | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
treatment_canton | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
treatment_canton | NMTOKEN | BE | the canton is BE - Bern
treatment_canton | NMTOKEN | BL | the canton is BL - Baselland
treatment_canton | NMTOKEN | BS | the canton is BS - Basel
treatment_canton | NMTOKEN | FR | the canton is FR - Fribourg
treatment_canton | NMTOKEN | GE | the canton is GE - Geneva
treatment_canton | NMTOKEN | GL | the canton is GL - Glarus
treatment_canton | NMTOKEN | GR | the canton is GR - Graubünden
treatment_canton | NMTOKEN | JU | the canton is JU - Jura
treatment_canton | NMTOKEN | LU | the canton is LU - Lucerne
treatment_canton | NMTOKEN | NE | the canton is NE - Neuchâtel
treatment_canton | NMTOKEN | NW | the canton is NW - Nidwalden
treatment_canton | NMTOKEN | OW | the canton is OW - Obwalden
treatment_canton | NMTOKEN | SG | the canton is SG - St. Gallen
treatment_canton | NMTOKEN | SH | the canton is SH - Schaffhausen
treatment_canton | NMTOKEN | SO | the canton is SO - Solothurn
treatment_canton | NMTOKEN | SZ | the canton is SZ - Schwyz
treatment_canton | NMTOKEN | TI | the canton is TI - Ticino
treatment_canton | NMTOKEN | TG | the canton is TG - Thurgau
treatment_canton | NMTOKEN | UR | the canton is UR - Uri
treatment_canton | NMTOKEN | VD | the canton is VD - Vaud
treatment_canton | NMTOKEN | VS | the canton is VS - Valais
treatment_canton | NMTOKEN | ZG | the canton is ZG - Zug
treatment_canton | NMTOKEN | ZH | the canton is ZH - Zürich
treatment_canton | NMTOKEN | LI | the country is LI - Liechtenstein
treatment_canton | NMTOKEN | A | the country is A - Austria
treatment_canton | NMTOKEN | D | the country is D - Germany
treatment_canton | NMTOKEN | F | the country is F - France
treatment_canton | NMTOKEN | I | the country is I - Italy
treatment_reason | NMTOKEN | disease | the reason of treatment is a disease
treatment_reason | NMTOKEN | accident | the reason of treatment is an accident
treatment_reason | NMTOKEN | maternity | the reason of treatment is a maternity
treatment_reason | NMTOKEN | prevention | the reason of treatment is prevention
treatment_reason | NMTOKEN | birthdefect | the reason of treatment a birthdefect
treatment_reason | NMTOKEN | unknown | the reason of treatment is unknown (or something not mentioned above)
treatment_type | NMTOKEN | ambulatory | the treatment type is ambulatory (default)
treatment_type | NMTOKEN | stationary | the treatment type is stationary
source <complexType name="treatmentType">
<attribute name="date_begin" type="dateTime" use="required"/>
<attribute name="date_end" type="dateTime" use="required"/>
<attribute name="treatment_days" type="duration" use="required"/>
<attribute name="treatment_canton" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="AG"/>
<enumeration value="AI"/>
<enumeration value="AR"/>
<enumeration value="BE"/>
<enumeration value="BL"/>
<enumeration value="BS"/>
<enumeration value="FR"/>
<enumeration value="GE"/>
<enumeration value="GL"/>
<enumeration value="GR"/>
<enumeration value="JU"/>
<enumeration value="LU"/>
<enumeration value="NE"/>
<enumeration value="NW"/>
<enumeration value="OW"/>
<enumeration value="SG"/>
<enumeration value="SH"/>
<enumeration value="SO"/>
<enumeration value="SZ"/>
<enumeration value="TI"/>
<enumeration value="TG"/>
<enumeration value="UR"/>
<enumeration value="VD"/>
<enumeration value="VS"/>
<enumeration value="ZG"/>
<enumeration value="ZH"/>
<enumeration value="LI"/>
<enumeration value="A"/>
<enumeration value="D"/>
<enumeration value="F"/>
<enumeration value="I"/>
</restriction>
</simpleType>
</attribute>
<attribute name="treatment_type" default="ambulatory">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="ambulatory"/>
<enumeration value="stationary"/>
</restriction>
</simpleType>
</attribute>
<attribute name="treatment_reason" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="disease"/>
<enumeration value="accident"/>
<enumeration value="maternity"/>
<enumeration value="prevention"/>
<enumeration value="birthdefect"/>
<enumeration value="unknown"/>
</restriction>
</simpleType>
</attribute>
<attribute name="tiers_mode" default="TP">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="TP"/>
<enumeration value="TG"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType uvgLawType

diagram
namespace http://sumex1.net/ccr
used by
element planningDataType/uvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id ccr:stringType1_35
case_id ccr:stringType1_35
case_date | dateTime
ssn ccr:ssnPartyType
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance,
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
source <complexType name="uvgLawType">
<attribute name="insured_id" type="ccr:stringType1_35"/>
<attribute name="case_id" type="ccr:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="ssn" type="ccr:ssnPartyType"/>
</complexType>


complexType vvgLawType

diagram
namespace http://sumex1.net/ccr
used by
element planningDataType/vvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id ccr:stringType1_35
case_id ccr:stringType1_35
case_date | dateTime
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
source <complexType name="vvgLawType">
<attribute name="insured_id" type="ccr:stringType1_35"/>
<attribute name="case_id" type="ccr:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
</complexType>


complexType xenc:AgreementMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
used by
element xenc:AgreementMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="AgreementMethodType" mixed="true">
<sequence>
<element name="KA-Nonce" type="base64Binary" minOccurs="0"/>
<!-- <element ref="ds:DigestMethod" minOccurs="0"/> -->
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
<element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


element xenc:AgreementMethodType/KA-Nonce

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KA-Nonce" type="base64Binary" minOccurs="0"/>


element xenc:AgreementMethodType/OriginatorKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


element xenc:AgreementMethodType/RecipientKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


complexType xenc:CipherDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:CipherValue xenc:CipherReference
used by
element xenc:CipherData
source <complexType name="CipherDataType">
<choice>
<element name="CipherValue" type="base64Binary"/>
<element ref="xenc:CipherReference"/>
</choice>
</complexType>


complexType xenc:CipherReferenceType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:Transforms
used by
element xenc:CipherReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="CipherReferenceType">
<choice>
<element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>
</choice>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptedDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
element xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedDataType">
<complexContent>
<extension base="xenc:EncryptedType"/>
</complexContent>
</complexType>


complexType xenc:EncryptedKeyType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
used by
element xenc:EncryptedKey
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source <complexType name="EncryptedKeyType">
<complexContent>
<extension base="xenc:EncryptedType">
<sequence>
<element ref="xenc:ReferenceList" minOccurs="0"/>
<element name="CarriedKeyName" type="string" minOccurs="0"/>
</sequence>
<attribute name="Recipient" type="string" use="optional"/>
</extension>
</complexContent>
</complexType>


element xenc:ReferenceList

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
content complex
children | xenc:DataReference xenc:KeyReference
used by
complexType xenc:EncryptedKeyType
source <element name="ReferenceList">
<complexType>
<choice maxOccurs="unbounded">
<element name="DataReference" type="xenc:ReferenceType"/>
<element name="KeyReference" type="xenc:ReferenceType"/>
</choice>
</complexType>
</element>


element xenc:EncryptedKeyType/CarriedKeyName

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | string
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="CarriedKeyName" type="string" minOccurs="0"/>


complexType xenc:EncryptedType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
abstract true
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexTypes xenc:EncryptedDataType xenc:EncryptedKeyType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedType" abstract="true">
<sequence>
<element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="xenc:CipherData"/>
<element ref="xenc:EncryptionProperties" minOccurs="0"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
</complexType>


complexType xenc:EncryptionMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KeySize xenc:OAEPparams
used by
element xenc:EncryptedType/EncryptionMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="EncryptionMethodType" mixed="true">
<sequence>
<element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>
<element name="OAEPparams" type="base64Binary" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptionPropertiesType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:EncryptionProperty
used by
element xenc:EncryptionProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="EncryptionPropertiesType">
<sequence>
<element ref="xenc:EncryptionProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType xenc:EncryptionPropertyType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
properties
mixed true
used by
element xenc:EncryptionProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source <complexType name="EncryptionPropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
</choice>
<attribute name="Target" type="anyURI" use="optional"/>
<attribute name="Id" type="ID" use="optional"/>
<anyAttribute namespace="http://www.w3.org/XML/1998/namespace"/>
</complexType>


complexType xenc:ReferenceType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
used by
elements xenc:ReferenceList/DataReference xenc:ReferenceList/KeyReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="ReferenceType">
<sequence>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:TransformsType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | ds:Transform
used by
element xenc:CipherReferenceType/Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType zipType

diagram
namespace | http://sumex1.net/ccr
type | extension of ccr:stringType1_9
properties
base ccr:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode ccr:stringType1_9
countrycode | ccr:stringType1_3 | CH
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
Extensions
Annotation | Base
Definition for the zip container (a subcontainer of an address definition) giving the zip code | ccr:stringType1_9
source <complexType name="zipType">
<simpleContent>
<extension base="ccr:stringType1_9">
<attribute name="statecode" type="ccr:stringType1_9"/>
<attribute name="countrycode" type="ccr:stringType1_3" default="CH"/>
</extension>
</simpleContent>
</complexType>


element ds:Manifest

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ManifestType
properties
content complex
children | ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Manifest" type="ds:ManifestType"/>


element ds:SignatureProperties

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertiesType
properties
content complex
children | ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureProperties" type="ds:SignaturePropertiesType"/>


element xenc:AgreementMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:AgreementMethodType
properties
content | complex
mixed | true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="AgreementMethod" type="xenc:AgreementMethodType"/>


element xenc:EncryptedKey

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedKeyType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source | <element name="EncryptedKey" type="xenc:EncryptedKeyType"/>


element xenc:ReferenceList/DataReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="DataReference" type="xenc:ReferenceType"/>


element xenc:ReferenceList/KeyReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="KeyReference" type="xenc:ReferenceType"/>


simpleType ds:CryptoBinary

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
elements ds:RSAKeyValueType/Exponent ds:DSAKeyValueType/G ds:DSAKeyValueType/J ds:RSAKeyValueType/Modulus ds:DSAKeyValueType/P ds:DSAKeyValueType/PgenCounter ds:DSAKeyValueType/Q ds:DSAKeyValueType/Seed ds:DSAKeyValueType/Y
source <simpleType name="CryptoBinary">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:DigestValueType

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
element ds:DigestValue
source <simpleType name="DigestValueType">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:HMACOutputLengthType

namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
used by
element ds:SignatureMethodType/HMACOutputLength
source <simpleType name="HMACOutputLengthType">
<restriction base="integer"/>
</simpleType>


simpleType eanPartyType

namespace | http://sumex1.net/ccr
type | restriction of string
used by
attributes billerAddressType/@ean_party providerAddressType/@ean_party insuranceAddressType/@ean_party debitorAddressType/@ean_party referrerAddressType/@ean_party transportType/@from transportType/@to transportType/via/@via
facets
pattern ([0-9]{13})
source <simpleType name="eanPartyType">
<restriction base="string">
<pattern value="([0-9]{13})"/>
</restriction>
</simpleType>


simpleType nifPartyType

namespace | http://sumex1.net/ccr
type | restriction of string
used by
attribute ivgLawType/@nif
facets
pattern [0-9]{1,7}
source <simpleType name="nifPartyType">
<restriction base="string">
<pattern value="[0-9]{1,7}"/>
</restriction>
</simpleType>


simpleType nonEmptyStringType

namespace | http://sumex1.net/ccr
type | restriction of string
facets
minLength 1
source <simpleType name="nonEmptyStringType">
<restriction base="string">
<minLength value="1"/>
</restriction>
</simpleType>


simpleType ssnPartyType

namespace | http://sumex1.net/ccr
type | restriction of string
used by
attributes patientAddressType/@ssn uvgLawType/@ssn ivgLawType/@ssn mvgLawType/@ssn
facets
pattern [0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}|438[0-9]{10}
source <simpleType name="ssnPartyType">
<restriction base="string">
<pattern value="[0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}|438[0-9]{10}"/>
</restriction>
</simpleType>


simpleType stringType1_12

namespace | http://sumex1.net/ccr
type | restriction of string
facets
minLength | 1
maxLength | 12
source <simpleType name="stringType1_12">
<restriction base="string">
<minLength value="1"/>
<maxLength value="12"/>
</restriction>
</simpleType>


simpleType stringType1_15

namespace | http://sumex1.net/ccr
type | restriction of string
used by
attributes nursinghomeCareType/@care_demand_level planningRecordType/@catalog_type postpartumCareType/@planning_catalog homeCareType/@planning_catalog nursinghomeCareType/@planning_catalog billerAddressType/@uid_number
facets
minLength | 1
maxLength | 15
source <simpleType name="stringType1_15">
<restriction base="string">
<minLength value="1"/>
<maxLength value="15"/>
</restriction>
</simpleType>


simpleType stringType1_25

namespace | http://sumex1.net/ccr
type | restriction of string
used by
elements telecomAddressType/fax telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source <simpleType name="stringType1_25">
<restriction base="string">
<minLength value="1"/>
<maxLength value="25"/>
</restriction>
</simpleType>


simpleType stringType1_255

namespace | http://sumex1.net/ccr
type | restriction of string
used by
attribute documentType/@filename
facets
minLength | 1
maxLength | 255
source <simpleType name="stringType1_255">
<restriction base="string">
<minLength value="1"/>
<maxLength value="255"/>
</restriction>
</simpleType>


simpleType stringType1_3

namespace | http://sumex1.net/ccr
type | restriction of string
used by
attribute zipType/@countrycode
facets
minLength | 1
maxLength | 3
source <simpleType name="stringType1_3">
<restriction base="string">
<minLength value="1"/>
<maxLength value="3"/>
</restriction>
</simpleType>


simpleType stringType1_30

namespace | http://sumex1.net/ccr
type | restriction of string
used by
attributes planningRecordType/@catalog_code serviceRecordType/@tariff_code
facets
minLength | 1
maxLength | 30
source <simpleType name="stringType1_30">
<restriction base="string">
<minLength value="1"/>
<maxLength value="30"/>
</restriction>
</simpleType>


simpleType stringType1_35

namespace | http://sumex1.net/ccr
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname personType/givenname postalAddressType/pobox postalAddressType/street personType/subaddressing companyType/subaddressing
attributes | patientAddressType/card/@card_id orgLawType/@case_id mvgLawType/@case_id kvgLawType/@case_id vvgLawType/@case_id uvgLawType/@case_id orgLawType/@insured_id mvgLawType/@insured_id kvgLawType/@insured_id vvgLawType/@insured_id uvgLawType/@insured_id creditType/@request_id personType/@salutation documentType/@title personType/@title patientAddressType/card/@validation_id patientAddressType/card/@validation_server
facets
minLength | 1
maxLength | 35
source <simpleType name="stringType1_35">
<restriction base="string">
<minLength value="1"/>
<maxLength value="35"/>
</restriction>
</simpleType>


simpleType stringType1_350

namespace | http://sumex1.net/ccr
type | restriction of string
used by
element | bodyType/remark
attributes | planningRecordType/@catalog_name planningRecordType/@remark serviceRecordType/@remark billerAddressType/@specialty providerAddressType/@specialty referrerAddressType/@specialty serviceRecordType/@tariff_name
facets
minLength | 1
maxLength | 350
source <simpleType name="stringType1_350">
<restriction base="string">
<minLength value="1"/>
<maxLength value="350"/>
</restriction>
</simpleType>


simpleType stringType1_50

namespace | http://sumex1.net/ccr
type | restriction of string
used by
attributes softwareType/@copyright dependsOnType/@copyright softwareType/@description dependsOnType/@description softwareType/@name dependsOnType/@name
facets
minLength | 1
maxLength | 50
source <simpleType name="stringType1_50">
<restriction base="string">
<minLength value="1"/>
<maxLength value="50"/>
</restriction>
</simpleType>


simpleType stringType1_64

namespace | http://sumex1.net/ccr
type | restriction of string
facets
minLength | 1
maxLength | 64
source <simpleType name="stringType1_64">
<restriction base="string">
<minLength value="1"/>
<maxLength value="64"/>
</restriction>
</simpleType>


simpleType stringType1_70

namespace | http://sumex1.net/ccr
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 70
source <simpleType name="stringType1_70">
<restriction base="string">
<minLength value="1"/>
<maxLength value="70"/>
</restriction>
</simpleType>


simpleType stringType1_9

namespace | http://sumex1.net/ccr
type | restriction of string
used by
complexType | zipType
attribute | zipType/@statecode
facets
minLength | 1
maxLength | 9
source <simpleType name="stringType1_9">
<restriction base="string">
<minLength value="1"/>
<maxLength value="9"/>
</restriction>
</simpleType>


simpleType zsrPartyType

namespace | http://sumex1.net/ccr
type | restriction of string
used by
attributes billerAddressType/@zsr providerAddressType/@zsr referrerAddressType/@zsr
facets
pattern [A-Z][0-9]{6}|[0-9]{6}[A-Z]
source <simpleType name="zsrPartyType">
<restriction base="string">
<pattern value="[A-Z][0-9]{6}|[0-9]{6}[A-Z]"/>
</restriction>
</simpleType>


simpleType xenc:KeySizeType

namespace | http://www.w3.org/2001/04/xmlenc#
type | integer
used by
element xenc:EncryptionMethodType/KeySize
source <simpleType name="KeySizeType">
<restriction base="integer"/>
</simpleType>